Installer import into contrib (real import this time)
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / sysutils / dfuife_curses / Makefile
1 # New ports collection makefile for:    dfuife_curses
2 # Date created:                 May 13, 2004
3 # Whom:                         Chris Pressey <cpressey@catseye.mine.nu>
4
5 PORTNAME=       dfuife_curses
6 PORTVERSION=    1.5
7 INTERNAL=       YES
8 CATEGORIES=     sysutils
9 DISTNAME=       ${PORTNAME}-${PORTVERSION}
10 WRKSRC=         work/ncurses
11
12 LIB_DEPENDS=    aura.3:${PORTSDIR}/devel/libaura \
13                 dfui.4:${PORTSDIR}/sysutils/libdfui
14
15 .if defined(WITH_NLS)
16 LIB_DEPENDS:=   ${LIB_DEPENDS} \
17                 intl.6:${PORTSDIR}/devel/gettext
18 .endif
19
20 MAINTAINER=     cpressey@catseye.mine.nu
21 COMMENT=        DFUI curses frontend
22
23 PLIST_FILES=    sbin/dfuife_curses share/dfuife_curses/fred.txt
24 .if defined(WITH_NLS)
25 PLIST_FILES+=   share/locale/ru/LC_MESSAGES/dfuife_curses.mo
26 .endif
27
28 .if defined(WITH_NLS)
29 LOCALEDIR=      ${LOCALBASE}/share/locale
30 LANGUAGES=      ru
31 .endif
32
33 do-fetch:
34         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
35                 ${ECHO_MSG};                                                    \
36                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
37                 ${ECHO_MSG};                                                    \
38                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
39                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
40                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
41                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
42                 ${ECHO_MSG} "to create these distfiles.";                       \
43                 false;                                                          \
44         fi
45
46 do-install:
47         ${MKDIR} -p ${LOCALBASE}/share/dfuife_curses
48         ${INSTALL_PROGRAM} -o root -g wheel ${WRKSRC}/dfuife_curses ${LOCALBASE}/sbin/
49         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/fred.txt ${LOCALBASE}/share/dfuife_curses/
50 .if defined(WITH_NLS)
51         for _language in ${LANGUAGES}; do \
52                 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/po/$${_language}.mo \
53                     ${LOCALEDIR}/$${_language}/LC_MESSAGES/${PORTNAME}.mo; \
54         done
55 .endif
56
57 OSTYPE!=sysctl -n kern.ostype
58
59 .if ${OSTYPE} == "FreeBSD"
60 .include <bsd.port.mk>
61 .endif
62
63 .if ${OSTYPE} == "DragonFly"
64 .include <bsd.dfport.mk>
65 .endif
66