Require 1.3.4 before installworld.
authorJoerg Sonnenberger <joerg@dragonflybsd.org>
Tue, 2 Aug 2005 13:07:50 +0000 (13:07 +0000)
committerJoerg Sonnenberger <joerg@dragonflybsd.org>
Tue, 2 Aug 2005 13:07:50 +0000 (13:07 +0000)
Makefile.inc1

index a9cbaa6..0ad9aa6 100644 (file)
@@ -1,6 +1,6 @@
 #
 # $FreeBSD: src/Makefile.inc1,v 1.141.2.62 2003/04/06 19:54:00 dwmalone Exp $
-# $DragonFly: src/Makefile.inc1,v 1.75 2005/07/26 21:15:19 joerg Exp $
+# $DragonFly: src/Makefile.inc1,v 1.76 2005/08/02 13:07:50 joerg Exp $
 #
 # Make command line options:
 #      -DMAKE_KERBEROS5 to build Kerberos5
@@ -408,7 +408,7 @@ installcheck:
        @pw groupshow _pflogd || (echo "You may need to run 'make preupgrade' first"; exit 1)
        @pw groupshow _ntp || (echo "You may need to run 'make preupgrade' first"; exit 1)
 .if !defined(DESTDIR) || ${DESTDIR} == "" || ${DESTDIR} == "/"
-       @case `uname -r` in 1.2*|1.3-*|1.3.0-*|1.3.1-*) echo "You must upgrade your kernel to at least 1.3.2 and reboot before you can safely installworld, due to the unsupported ELF ABI tagging" ; exit 1;; esac
+       @case `uname -r` in 1.2*|1.3-*|1.3.0-*|1.3.1-*|1.3.2-*|1.3.3-*) echo "You must upgrade your kernel to at least 1.3.4 and reboot before you can safely installworld, due to stat(2) ABI changes" ; exit 1;; esac
 .endif
 
 # distributeworld