Make hack compile with gcc40: Remove previously deprecated, now