Add date
[ikiwiki.git] / docs / supportedhardware / index.mdwn
index 81b30a7..c360c88 100644 (file)
@@ -1,5 +1,7 @@
 DragonFly BSD runs on recent PCs supporting the i386 or amd64 (x86_64) microarchitectures.
 
+This page only references a small part of the hardware which can potentially run with DragonFly; if a piece of hardware is not in this list this only means nobody has tested it or reported its working state.
+
 ## System Boards and chipsets
 
 Most desktop and server class mainboards using Intel or AMD chipsets are supported; the devices listed in this section are known to run really well with DragonFly BSD.
@@ -17,8 +19,10 @@ Atom boards
 
 Xeon boards
 
+* Supermicro X8DTH-iF
 * Supermicro X8STi and X8STi-F
 * Supermicro X8SAX
+* Supermicro X9 series
 
 Opteron boards
 
@@ -58,6 +62,10 @@ Devices supported by the mfi(4) driver
 
 * LSI MegaRAID SAS 8408E
 
+Devices supported by the mps(4) driver
+
+* LSI Logic SAS2008-based controllers such as Asus PIKE 2008
+
 Devices supported by the twa(4) driver
 
 * 3Ware 9690SA-4i
@@ -81,10 +89,19 @@ based on the Intel 82575 and 82576 Ethernet controller chips.
 
 The re(4) driver supports Realtek RTL8169, RTL8169S, RTL8110S, RTL8168S, RTL8111S and RTL8101E ethernet chipsets
 
+### 10 Gigabit ethernet adapters
+
+The mxge(4) driver supports 10 Gigabit Ethernet adapters based on the Myricom LANai Z8E chips
+
+The ixgbe(4) driver supports the Intel PRO/10GbE adapters based on the 82598 and 82599 chip families
+
 ## Broken hardware
 
 The products listed in this section are known to have some serious problems or not work at all with DragonFly BSD.
 
 * Asus M2N4-SLI: USB is not working on this model
 
-* Highpoint RAID adapters: the driver for these adapters uses a binary blob which causes panics from time to time
+* Highpoint RocketRAID 17xx, 22xx, 23xx and 25xx RAID adapters: there is no driver for these adapters. A FreeBSD driver exists, but it uses a binary blob which causes panics. Highpoint
+has not been cooperative in documenting their hardware so that a proper driver can be written.
+
+* HP Pavilion laptops: as of 2012-07 it is impossible to run DragonFly on them due to broken ACPI interrupt routing in their firmware.