Rewrite graphic drivers section
authorftigeot <ftigeot@web>
Tue, 3 Jun 2014 21:19:29 +0000 (21:19 +0000)
committerCharlie Root <root@leaf.dragonflybsd.org>
Tue, 3 Jun 2014 21:19:29 +0000 (21:19 +0000)
release38/index.mdwn

index cce2b21..955138b 100644 (file)
@@ -13,9 +13,14 @@ PAM is now usable for other authentications systems in DragonFly.  DragonFly now
 
 USB4BSD is now default in DragonFly.  USB3 devices are supported, though some network devices may not be recognized. 
 
-### Experimental i915 and KMS support
+### Graphic drivers
 
-Support for newer Intel and ATI chipsets is present in the system.  This may not work for every hardware combination, but a number of users have reported success with hardware-accelerated video using this update.  Intel chipsets newer than Ivy Bridge may have trouble; switch to the vesa driver if this happens to you.
+The drm/i915 driver had originally been ported from FreeBSD. An ongoing synchronization job with the version present in the Linux 3.8 branch is now going on. The mid-term goal is to be able to use GPUs included in Haswell and ValleyView/Bay Trail processors.  
+Supported GPUs are currently limited to HD4000 from the Ivy Bridge processor generation.
+
+Even if this goal has not been reached yet, the partial synchronization with the drm/i915 implementation from Linux 3.8.x has already allowed many bugs to be fixed and general driver stability to be improved.
+
+The drm/ttm memory manager used by the drm/radeon driver has been partially synchronized with the version present in Linux 3.9, improving its stability. Howewer, many issues remain and thus Xorg still doesn't use the drm/radeon driver by default.
 
 ### Last 32-bit release