add "Improve compatibility of libdevattr with Linux' libudev"
authoralexh <alexh@web>
Fri, 25 Feb 2011 20:44:00 +0000 (12:44 -0800)
committerCharlie <root@leaf.dragonflybsd.org>
Fri, 25 Feb 2011 20:44:00 +0000 (12:44 -0800)
docs/developer/gsocprojectspage/index.mdwn

index 9b1a2c8..d58becf 100644 (file)
@@ -301,4 +301,18 @@ Meta information:
 * Difficulty: Medium
 * Contact point: kernel@crater.dragonflybsd.org
 
+---
+
+##### Improve compatibility of libdevattr with Linux' libudev
+* Our libdevattr has an API which is mostly compatible with Linux' libudev, but it is doubtful that any Linux application making use of libudev would run out of the box on DragonFly with libdevattr.
+* The aim of this project is to identify the shortcomings of libdevattr and fix them so that some common libudev applications work with our libdevattr. This might involve some kernel hacking to improve our kern_udev and definitely includes some grunt work of "tagging" subsystems with the kern_udev API. Most of the work will be in userland, though, working on udevd and libdevattr.
+
+Meta information:
+
+* Prerequisites: C, familiarity with Linux' libudev would be a plus
+* Difficulty: Medium
+* Contact point: kernel@crater.dragonflybsd.org , Alex Hornung <alexh@dragonflybsd.org>
+
+
+
  (please add)