Update the Linux applications on DragonFly/x86_64 proposal
authorftigeot <ftigeot@web>
Wed, 6 Mar 2013 10:16:43 +0000 (02:16 -0800)
committerCharlie Root <root@leaf.dragonflybsd.org>
Wed, 6 Mar 2013 10:16:43 +0000 (02:16 -0800)
docs/developer/gsocprojectspage/index.mdwn

index 3d3adc7..00c48dd 100644 (file)
@@ -22,8 +22,8 @@ Legend:
 
 ---
 
 
 ---
 
-##### Implement amd64 Linux compatibility for x86_64 64-bit kernel
-* Add a syscall table which translates 64-bit Linux system calls to DragonFly ones
+##### Implement Linux compatibility for the x86_64 DragonFly kernel
+* Add a syscall table which translates Linux system calls to DragonFly ones
 * Add support for ELF binary detection.
 
 DragonFly/i386 supports the execution of 32 bit Linux binaries; it
 * Add support for ELF binary detection.
 
 DragonFly/i386 supports the execution of 32 bit Linux binaries; it
@@ -32,9 +32,11 @@ for 64-bit systems.
 
 Some of the other *BSD systems may already have implemented such a mechanism.
 
 
 Some of the other *BSD systems may already have implemented such a mechanism.
 
+Given Linux software available in pkgsrc and dports is i386 only at this date (2013-03-06), it would be more practical to avoid working on amd64 linux applications at first.
+
 Meta information:
 
 Meta information:
 
-* Prerequisites: C, amd64 architecture knowledge
+* Prerequisites: C, i386 and amd64 architecture knowledge
 * Difficulty: Moderate to difficult
 * Contact point: kernel@crater.dragonflybsd.org
 
 * Difficulty: Moderate to difficult
 * Contact point: kernel@crater.dragonflybsd.org