update Tue Jun 22 06:37:08 PDT 2010
[pkgsrc.git] / devel / atk / Makefile
1 # $NetBSD: Makefile,v 1.70 2009/10/21 15:37:24 drochner Exp $
2 #
3
4 DISTNAME=               atk-1.28.0
5 CATEGORIES=             devel
6 MASTER_SITES=           ${MASTER_SITE_GNOME:=sources/atk/1.28/}
7 EXTRACT_SUFX=           .tar.bz2
8
9 MAINTAINER=             pkgsrc-users@NetBSD.org
10 HOMEPAGE=               http://developer.gnome.org/projects/gap/
11 COMMENT=                Set of interfaces for accessibility
12 LICENSE=                gnu-lgpl-v2
13
14 PKG_INSTALLATION_TYPES= overwrite pkgviews
15 PKG_DESTDIR_SUPPORT=    user-destdir
16
17 USE_TOOLS+=             gmake pkg-config msgfmt
18 GNU_CONFIGURE=          yes
19 USE_PKGLOCALEDIR=       yes
20 USE_LANGUAGES+=         c99
21 USE_LIBTOOL=            yes
22 PKGCONFIG_OVERRIDE=     atk.pc.in
23
24 # glib-mkenums overflows a 2048kb stack on atkobject.h
25 UNLIMIT_RESOURCES=      stacksize
26
27 SUBST_CLASSES+=         loc
28 SUBST_STAGE.loc=        pre-configure
29 SUBST_MESSAGE.loc=      Fixing invalid use of AM_GLIB_DEFINE_LOCALEDIR.
30 SUBST_FILES.loc=        configure
31 SUBST_SED.loc=          -e 's,^\(\#define ATK_LOCALEDIR\).*,\1 "${PREFIX}/${PKGLOCALEDIR}/locale",'
32
33 # Workaround for Upstream Bug#562310.
34 # for more detail, see also PR#41475.
35 TOOLS_NOOP+=    gtkdoc-rebase
36
37 .include "../../devel/gettext-lib/buildlink3.mk"
38 BUILDLINK_API_DEPENDS.glib2+=   glib2>=2.5.7
39 .include "../../devel/glib2/buildlink3.mk"
40
41 .include "../../mk/bsd.pkg.mk"