pkgsrc.git
3 years agoUpdate to 10100929, with important fixes in write and rename master
manu [Wed, 29 Sep 2010 08:08:57 +0000 (08:08 +0000)]
Update to 10100929, with important fixes in write and rename

3 years agoUpdated www/ikiwiki to 3.20100926
schmonz [Wed, 29 Sep 2010 01:04:15 +0000 (01:04 +0000)]
Updated www/ikiwiki to 3.20100926

3 years agoUpdate to 3.20100926. From the changelog:
schmonz [Wed, 29 Sep 2010 01:03:59 +0000 (01:03 +0000)]
Update to 3.20100926. From the changelog:

* meta: Ensure that the url specified by xrds-location is absolute.
* attachment: Fix attachment file size display.
* Propigate PATH into wrapper.
* htmlbalance: Fix compatibility with HTML::Tree 4.0. (smcv)

Updating during the freeze for bugfixes to a leaf package.

3 years agoAdd the necessary glue to hook Ruby into the multi-version framework.
joerg [Tue, 28 Sep 2010 20:24:25 +0000 (20:24 +0000)]
Add the necessary glue to hook Ruby into the multi-version framework.
This allows lang/ruby18 and lang/ruby19 to coexist in bulk builds.

Discussed with taca@

3 years ago+# ymtype.so wants to link -llzh before it's finished building
wiz [Tue, 28 Sep 2010 18:58:39 +0000 (18:58 +0000)]
+# ymtype.so wants to link -llzh before it's finished building
+MAKE_JOBS_SAFE=                no

3 years agofix local patch; void function cannot return vaule.
tnn [Tue, 28 Sep 2010 17:50:07 +0000 (17:50 +0000)]
fix local patch; void function cannot return vaule.
reported by <BugeyeD> in #pkgsrc

3 years ago+ anjuta-2.32.0 [GNOME 2.32], brasero-2.32.0, bzr-2.2.1, cheese-2.32.0
wiz [Tue, 28 Sep 2010 15:48:17 +0000 (15:48 +0000)]
+ anjuta-2.32.0 [GNOME 2.32], brasero-2.32.0, bzr-2.2.1, cheese-2.32.0
  [GNOME 2.32], eog-2.32.0, evince-2.32.0, evolution-webcal-2.32.0,
  gdm-2.32.0 [GNOME 2.32], gedit-2.30.4, glib2-2.26.0,
  gnome-keyring-2.32.0, gnome-netstatus-2.28.2 [GNOME 2.32],
  gnome-nettool-2.32.0 [GNOME 2.32], gnome-packagekit-2.32.0 [GNOME
  2.32], gnome-power-manager-2.32.0 [GNOME 2.32], gnome-session-2.32.0
  [GNOME 2.32, wants DeviceKit-power], gnome-system-monitor-2.28.2,
  gnome-system-tools-2.32.0 [GNOME 2.32], gnome-user-share-2.30.1
  [GNOME 2.32], gnome-utils-2.32.0, gnome-vfs-2.24.4, gthumb-2.12.0,
  gtkmm-2.22.0, gtksourceview2-2.10.5, horde-3.3.9, libbonoboui-2.24.4,
  libgnome-keyring-2.32.0, libgnomekbd-2.32.0, libgnomeprint-2.18.8,
  libgnomeprintui-2.18.6, libgtop-2.28.2, liblastfm-0.3.3,
  liboobs-2.32.0 [GNOME 2.32], libsoup24-2.32.0, mathomatic-15.2.2,
  meld-1.4.0, mousetweaks-2.32.0 [GNOME 2.32], orca-2.32.0 [GNOME
  2.32], py-gobject-2.26.0, sabayon-2.30.1 [GNOME 2.30], seahorse-2.32.0,
  sound-juicer-2.32.0, swfdec-gnome-2.30.1, xf86-video-ati-6.13.2.

3 years agoMention libgnome-keyring package (hi drochner!).
wiz [Tue, 28 Sep 2010 15:40:34 +0000 (15:40 +0000)]
Mention libgnome-keyring package (hi drochner!).

3 years agoReset maintainer.
wiz [Tue, 28 Sep 2010 13:21:33 +0000 (13:21 +0000)]
Reset maintainer.

3 years agoAdd workaround to make this compile with native X, from joerg.
wiz [Tue, 28 Sep 2010 13:11:26 +0000 (13:11 +0000)]
Add workaround to make this compile with native X, from joerg.
Shouldn't break modular X, says joerg.

3 years agoDon't hardcode "ruby18-" but use "${RUBY_PKGPREFIX}-".
taca [Tue, 28 Sep 2010 12:24:26 +0000 (12:24 +0000)]
Don't hardcode "ruby18-" but use "${RUBY_PKGPREFIX}-".

Fix build problem of ruby-gnome2 with ruby19.
(Although textproc/ruby-eruby has another problem with ruby19.)

3 years agoFixes build failure on MIPS arch, PR#43894.
obache [Tue, 28 Sep 2010 11:08:29 +0000 (11:08 +0000)]
Fixes build failure on MIPS arch, PR#43894.

3 years agoUpdated devel/pkg-config to 0.25nb1
dsainty [Tue, 28 Sep 2010 04:56:36 +0000 (04:56 +0000)]
Updated devel/pkg-config to 0.25nb1

3 years agopatch-ab is upstream now (PKG_CONFIG_LOG support). Remove the patch to
dsainty [Tue, 28 Sep 2010 04:52:41 +0000 (04:52 +0000)]
patch-ab is upstream now (PKG_CONFIG_LOG support).  Remove the patch to
avoid crashing with double free on glibc.

Bump PKGREVISION for new "not crash" functionality.

3 years agoLICENSE=modified-bsd
obache [Tue, 28 Sep 2010 04:36:41 +0000 (04:36 +0000)]
LICENSE=modified-bsd

3 years agoNo need to allow lower rubygems dependency any more since we have
taca [Tue, 28 Sep 2010 03:42:33 +0000 (03:42 +0000)]
No need to allow lower rubygems dependency any more since we have
rubygems 1.3.7.

3 years ago+ at-spi-1.32.0, atk-1.32.0, evolution-mapi-0.32.0 [GNOME 2.32],
wiz [Mon, 27 Sep 2010 20:04:11 +0000 (20:04 +0000)]
+ at-spi-1.32.0, atk-1.32.0, evolution-mapi-0.32.0 [GNOME 2.32],
  gcalctool-5.32.0, gnome-applets-2.32.0, gnome-color-manager-2.32.0
  [GNOME 2.32], gnome-control-center-2.32.0, gnome-desktop-2.32.0,
  gnome-games-2.32.0, gnome-menus-2.30.4, gnome-power-manager-2.32.0,
  gnome-session-2.32.0, gnome-settings-daemon-2.32.0,
  gnome-terminal-2.32.0, gucharmap-2.32.0, hamster-applet-2.32.0
  [GNOME 2.32], libbonobo-2.32.0, libgda-4.2.0 [GNOME 2.32],
  librep-0.91.0, librsvg2-2.32.0, libwnck-2.30.5, lzip-1.11,
  mdocml-1.10.6, rep-gtk-0.90.4, vte-0.26.0, xfontsel-1.0.3,
  xsm-1.0.2, xwininfo-1.1.0.

3 years agoNote PKGREVISION bump of tex-hyperref.
minskim [Mon, 27 Sep 2010 15:45:56 +0000 (15:45 +0000)]
Note PKGREVISION bump of tex-hyperref.

3 years agoUpdate dependencies of tex-hyperref.
minskim [Mon, 27 Sep 2010 15:45:35 +0000 (15:45 +0000)]
Update dependencies of tex-hyperref.

3 years ago* Fix build problem on NetBSD current, terminfo case.
taca [Mon, 27 Sep 2010 12:01:49 +0000 (12:01 +0000)]
* Fix build problem on NetBSD current, terminfo case.
* Add comments to each patch file.

3 years agoNo need a patch for configure, so no need to autoconf.
obache [Mon, 27 Sep 2010 11:15:24 +0000 (11:15 +0000)]
No need a patch for configure, so no need to autoconf.

3 years agoAlso need to buildlink with gettext-lib and zlib.
obache [Mon, 27 Sep 2010 10:41:42 +0000 (10:41 +0000)]
Also need to buildlink with gettext-lib and zlib.
They are in dependency_libs of libexiv2.la.
Should fixes PR#43914.

3 years agoUpdated textproc/py-sphinx to 1.0.1nb1
adam [Mon, 27 Sep 2010 10:30:33 +0000 (10:30 +0000)]
Updated textproc/py-sphinx to 1.0.1nb1

3 years agoPLIST fix
adam [Mon, 27 Sep 2010 10:29:22 +0000 (10:29 +0000)]
PLIST fix

3 years agoreplace obsolated '-r' option for nasm with '-v' in configure script.
obache [Mon, 27 Sep 2010 09:09:29 +0000 (09:09 +0000)]
replace obsolated '-r' option for nasm with '-v' in configure script.
per PR#43910 from Ryo ONODERA.

Furthermore, nasm is only required for mmx support.
Made mmx optionify and let to exactly depend on nasm with mmx option.
(disabled by default).

3 years agoUsing pkg-config in configure script.
obache [Mon, 27 Sep 2010 05:03:25 +0000 (05:03 +0000)]
Using pkg-config in configure script.

3 years agoFix build under NetBSD-current by avoiding a conflict between's popcount(3)
tron [Sun, 26 Sep 2010 23:15:18 +0000 (23:15 +0000)]
Fix build under NetBSD-current by avoiding a conflict between's popcount(3)
and locally defined functions of the same name.

Patch supplied by Sverre Froyen in private e-mail.

3 years ago+ digikam-1.4.0 [needs kdegraphics>=4.5.0], libgee-0.6.0,
wiz [Sun, 26 Sep 2010 21:46:31 +0000 (21:46 +0000)]
+ digikam-1.4.0 [needs kdegraphics>=4.5.0], libgee-0.6.0,
  redland-1.0.11, xload-1.1.0.

3 years ago+ davical-0.9.9.3, dbus-1.4.0, x264-devel-20100925.
wiz [Sun, 26 Sep 2010 16:00:06 +0000 (16:00 +0000)]
+ davical-0.9.9.3, dbus-1.4.0, x264-devel-20100925.

3 years agoAdd mips64 for OpenBSD, from jmc@openbsd.
wiz [Sun, 26 Sep 2010 15:20:10 +0000 (15:20 +0000)]
Add mips64 for OpenBSD, from jmc@openbsd.

3 years agoExpress dependency on py-expat.
gdt [Sun, 26 Sep 2010 13:53:47 +0000 (13:53 +0000)]
Express dependency on py-expat.

(The python world seems to think that xml parsing functions are part
of core Python and need not be mentioned.  Perhaps pkgsrc's way of
having py-expat is unusual and a bit of DESCR spiffage is in order,
but I'm not sure what's right.)

3 years agoNote update of lang/ruby19-base package to 1.9.2pl0nb1.
taca [Sun, 26 Sep 2010 13:17:13 +0000 (13:17 +0000)]
Note update of lang/ruby19-base package to 1.9.2pl0nb1.

3 years agoFix PLIST. It contained wrong name RUBY_GEM_HOME which was one of
taca [Sun, 26 Sep 2010 13:16:11 +0000 (13:16 +0000)]
Fix PLIST.  It contained wrong name RUBY_GEM_HOME which was one of
the candidate names for it.

Bump PKGREVISION.

3 years ago+ ImageMagick-6.6.4.7, calibre-0.7.20, gbrainy-1.52, gnome-pilot-2.32.0,
wiz [Sun, 26 Sep 2010 12:59:54 +0000 (12:59 +0000)]
+ ImageMagick-6.6.4.7, calibre-0.7.20, gbrainy-1.52, gnome-pilot-2.32.0,
  json-glib-0.12.0, kid3-1.5, libgsf-1.14.19, libtasn1-2.8,
  libtool-2.4, libtool-base-2.4, libtool-info-2.4, p5-PerlMagick-6.6.4.7,
  php-libawl-0.45, py-gtk2-2.22.0.

3 years agoFix gemspec syntax to fix build problem with ruby19.
taca [Sun, 26 Sep 2010 12:14:22 +0000 (12:14 +0000)]
Fix gemspec syntax to fix build problem with ruby19.
Ruby 1.8's gem (misc/rubygems) contains a patch to allow such a wrong
syntax of gemspec.  (I don't think this patch is a good idea now.)

Noted by joerg@ via private mail.

3 years agoexactly set --mode and --tag for libtool.
obache [Sun, 26 Sep 2010 11:27:21 +0000 (11:27 +0000)]
exactly set --mode and --tag for libtool.

3 years ago* convert bison dependency from BUILD_DEPENDS to USE_TOOLS.
obache [Sun, 26 Sep 2010 11:03:05 +0000 (11:03 +0000)]
* convert bison dependency from BUILD_DEPENDS to USE_TOOLS.
* exactly pass LEX to make, or using flex.
* MAKE_JOBS_SAFE=no

3 years agoOops, not user-destdir support.
obache [Sun, 26 Sep 2010 09:31:13 +0000 (09:31 +0000)]
Oops, not user-destdir support.
* switch to simply depend on wish.
* instead of replaceing prefix with subst, pass to install script.
* then avoid intaractive installation.

3 years ago* use SUBST for replace prefix
obache [Sun, 26 Sep 2010 08:48:00 +0000 (08:48 +0000)]
* use SUBST for replace prefix
* set LICENSE=original-bsd

3 years agofixes destdir installation.
obache [Sun, 26 Sep 2010 08:26:40 +0000 (08:26 +0000)]
fixes destdir installation.

3 years ago* set LICENSE=gnu-gpl-v2
obache [Sun, 26 Sep 2010 08:11:22 +0000 (08:11 +0000)]
* set LICENSE=gnu-gpl-v2
* fixes build with recent gmake.

3 years agoUpdated graphics/rabbit to 0.9.0
obache [Sun, 26 Sep 2010 07:10:16 +0000 (07:10 +0000)]
Updated graphics/rabbit to 0.9.0

3 years agoUpdate rabbit to 0.9.0.
obache [Sun, 26 Sep 2010 07:09:59 +0000 (07:09 +0000)]
Update rabbit to 0.9.0.

== Changes 0.9.0 from 0.6.5: 2010-09-26

Applied defalut custom tag styles.

=== Improvements

==== Theme

  * background-image-toolkit: Added vertical-align
    paramteter that specifies vertical position.

    Example:
      # image
      # src = lavie.png
      # relative-width = 30
      # align = right
      # vertical-align = top
      # relative-margin-right = -5

  * tag: New theme. It provides default style for some
    custome tags. The following custom tags are supports. It
    is enabled by default.

    * tag:x-large: Made specified text large.
    * tag:center: Placed specified text in center If no text
      is specified, block that has center tag is placed in
      center.
    * tag:right: Placed specified text in right If no text
      is specified, block that has right tag is placed in
      right.

    Example:
      (('tag:x-large:Large Text'))

      (('tag:center'))Centerized Text

      (('tag:right'))Right-Justified Text

==== RD

  * Supported recursive markup in (('('))('XXX:')((')')) markup.

  * Supported markup in cells in table.

=== Fix

  * Fixed missing require.
    [Reported by OBATA Akio]
  * Fixed aafigure's site URL.
    [Reported by kdmsnr]
  * Changed default align to center of
    background-image-toolkit theme for backward compatibility.
    [Suggested by nari]
  * Renamed Rabbitter to Rabbiter.

3 years agoGenerate html docs in build phase (instead of install phase).
wiz [Sat, 25 Sep 2010 12:29:01 +0000 (12:29 +0000)]
Generate html docs in build phase (instead of install phase).
gnome-doc-tool seems to ignore "-o html" so manually generate
the same effect.

Solves PLIST problem due to missing html files.

3 years ago* remove USE_LIBTOOLS, this package not using libtool.
obache [Sat, 25 Sep 2010 12:24:02 +0000 (12:24 +0000)]
* remove USE_LIBTOOLS, this package not using libtool.
* remove adding PYTHON=${PYTHONBIN} to CONFIGURE_ENV, it alredy in ALL_ENV.
* remove pre-install target, because no need, broke destdir installation
* some cosmetic fixes.

3 years agoNote update of the "wireshark" package to version 1.4.0.
tron [Sat, 25 Sep 2010 11:19:24 +0000 (11:19 +0000)]
Note update of the "wireshark" package to version 1.4.0.

3 years agoUpdate "wireshark" package to version 1.4.0. Change since version 1.2.10:
tron [Sat, 25 Sep 2010 11:19:10 +0000 (11:19 +0000)]
Update "wireshark" package to version 1.4.0. Change since version 1.2.10:
- The following bugs have been fixed:
  - Update time display in background. (Bug 1275)
  - Tshark returns 0 even with an invalid interface or capture
    filter. (Bug 4735)
- The following features are new (or have been significantly
  updated) since version 1.2:
  - The packet list internals have been rewritten and are now more
    efficient.
  - Columns are easier to use. You can add a protocol field as a
    column by right-clicking on its packet detail item, and you
    can adjust some column preferences by right-clicking the
    column header.
  - Preliminary Python scripting support has been added.
  - Many memory leaks have been fixed.
  - Packets can now be ignored (excluded from dissection), similar
    to the way they can be marked.
  - Manual IP address resolution is now supported.
  - Columns with seconds can now be displayed as hours, minutes
    and seconds.
  - You can now set the capture buffer size on UNIX and Linux if
    you have libpcap 1.0.0 or greater.
  - TShark no longer needs elevated privileges on UNIX or Linux to
    list interfaces. Only dumpcap requires privileges now.
  - Wireshark and TShark can enable 802.11 monitor mode directly
    if you have libpcap 1.0.0 or greater.
  - You can play RTP streams directly from the RTP Analysis
    window.
  - Capinfos and editcap now respectively support time order
    checking and forcing.
  - Wireshark now has a "jump to timestamp" command-line option.
  - You can open JPEG files directly in Wireshark.
- New Protocol Support
  3GPP Nb Interface RTP Multiplex, Access Node Control Protocol,
  Apple Network-MIDI Session Protocol, ARUBA encapsulated remote
  mirroring, Assa Abloy R3, Asynchronous Transfer Mode, B.A.T.M.A.N.
  Advanced Protocol, Bluetooth AMP Packet, Bluetooth OBEX, Bundle
  Protocol, CIP Class Generic, CIP Connection Configuration Object,
  CIP Connection Manager, CIP Message Router, collectd network data,
  Control And Provisioning of Wireless Access Points, Controller
  Area Network, Device Level Ring, DOCSIS Bonded Initial Ranging
  Message, Dropbox LAN sync Discovery Protocol, Dropbox LAN sync
  Protocol, DTN TCP Convergence Layer Protocol, EtherCAT Switch
  Link, Fibre Channel Delimiters, File Replication Service DFS-R,
  Gateway Load Balancing Protocol, Gigamon Header, GigE Vision
  Control Protocol, Git Smart Protocol, GSM over IP ip.access CCM
  sub-protocol, GSM over IP protocol as used by ip.access, GSM
  Radiotap, HI2Operations, Host Identity Protocol, HP encapsulated
  remote mirroring, HP NIC Teaming Heartbeat, IEC61850 Sampled
  Values, IEEE 1722 Protocol, InfiniBand Link, Interlink Protocol,
  IPv6 over IEEE 802.15.4, ISO 10035-1 OSI Connectionless
  Association Control Service, ISO 9548-1 OSI Connectionless Session
  Protocol, ISO 9576-1 OSI Connectionless Presentation Protocol,
  ITU-T Q.708 ISPC Analysis, Juniper Packet Mirror, Licklider
  Transmission Protocol, MPLS PW ATM AAL5 CPCS-SDU mode
  encapsulation, MPLS PW ATM Cell Header, MPLS PW ATM Control Word,
  MPLS PW ATM N-to-One encapsulation, no CW, MPLS PW ATM N-to-One
  encapsulation, with CW, MPLS PW ATM One-to-One or AAL5 PDU
  encapsulation, Multiple Stream Reservation Protocol, NetPerfMeter
  Protocol, NetScaler Trace, NexusWare C7 MTP, NSN FLIP, OMRON FINS
  Protocol, packetbb Protocol, Peer Network Resolution Protocol,
  PKIX Attribute Certificate, Pseudowire Padding, Server/Application
  State Protocol, Solaris IPNET, TN3270 Protocol, TN5250 Protocol,
  TRILL, Twisted Banana, UMTS FP Hint, UMTS MAC, UMTS Metadata, UMTS
  RLC, USB HID, USB HUB, UTRAN Iuh interface HNBAP signalling, UTRAN
  Iuh interface RUA signalling, V5.2, Vendor Specific Control
  Protocol, Vendor Specific Network Protocol, VMware Lab Manager,
  VXI-11 Asynchronous Abort, VXI-11 Core Protocol, VXI-11 Interrupt,
  X.411 Message Access Service, ZigBee Cluster Library
- Updated Protocol Support
  There are too many to list here.
- New and Updated Capture File Support
  Accellent 5Views, ASN.1 Basic Encoding Rules, Catapult DCT2000,
  Daintree SNA, Endace ERF, EyeSDN, Gammu DCT3 trace, IBM iSeries,
  JPEG/JFIF, libpcap, Lucent/Ascend access server trace, NetScaler,
  PacketLogger, pcapng, Shomiti/Finisar Surveyor, Sun snoop, Symbian
  OS btsnoop, Visual Networks

Pkgsrc changes:
A fix for the security vulnerability reported in SA41535 has been
integrated from the Wireshark SVN repository.

3 years agoUpdated x11/lablgtk to 2.14.2nb1
obache [Sat, 25 Sep 2010 11:19:08 +0000 (11:19 +0000)]
Updated x11/lablgtk to 2.14.2nb1

3 years ago* get glade option back, Error is not happend now.
obache [Sat, 25 Sep 2010 11:18:28 +0000 (11:18 +0000)]
* get glade option back, Error is not happend now.
* add some missing .cmxs files to PLIST.

Bump PKGREVISION.

3 years agoFix build with ruby-1.9, based on a suggestion by taca@.
wiz [Sat, 25 Sep 2010 10:16:46 +0000 (10:16 +0000)]
Fix build with ruby-1.9, based on a suggestion by taca@.

3 years agoFix destdir install.
wiz [Sat, 25 Sep 2010 09:41:39 +0000 (09:41 +0000)]
Fix destdir install.

3 years agoThis stopped using perl to build -- remove remaining perl occurrences.
wiz [Sat, 25 Sep 2010 09:39:32 +0000 (09:39 +0000)]
This stopped using perl to build -- remove remaining perl occurrences.
Build changes only, so no PKGREVISION++.

3 years agoNote update of the "tex-hyperref" package to version 6.81pnb1.
tron [Sat, 25 Sep 2010 09:37:04 +0000 (09:37 +0000)]
Note update of the "tex-hyperref" package to version 6.81pnb1.

3 years agoAccept versions newer than 2009nb1 of the "tex-ltxmisc" package as well.
tron [Sat, 25 Sep 2010 09:35:48 +0000 (09:35 +0000)]
Accept versions newer than 2009nb1 of the "tex-ltxmisc" package as well.

3 years agoupdate timestamp to avoid unwanted invoke of glib-genmarshal.
obache [Sat, 25 Sep 2010 08:45:33 +0000 (08:45 +0000)]
update timestamp to avoid unwanted invoke of glib-genmarshal.
(@GLIB_GENMARSHAL@ will not be replaced with configure script).

3 years agoreplace 8 spaces with a tab for recent gmake update.
obache [Sat, 25 Sep 2010 08:38:52 +0000 (08:38 +0000)]
replace 8 spaces with a tab for recent gmake update.

3 years agoNote update of www/contao29-translations package to 20100924.
taca [Sat, 25 Sep 2010 05:42:51 +0000 (05:42 +0000)]
Note update of www/contao29-translations package to 20100924.

3 years agoUpdate www/contao29-translations package to 20100924 (a leaf pacakge).
taca [Sat, 25 Sep 2010 05:42:05 +0000 (05:42 +0000)]
Update www/contao29-translations package to 20100924 (a leaf pacakge).

Update Persian langugage files to support Contao 2.9.1.

3 years agoNote the start of the freeze for new functionality in preparation for the
agc [Sat, 25 Sep 2010 01:02:41 +0000 (01:02 +0000)]
Note the start of the freeze for new functionality in preparation for the
pkgsrc-2010Q3 branch.

No new packages, and please get approval in advance before updating any
existing packages. Thanks!

3 years ago+ clutter-1.4.0
obache [Sat, 25 Sep 2010 00:37:03 +0000 (00:37 +0000)]
+ clutter-1.4.0

3 years ago+mailman-2.1.14, open-vm-tools-2010.09.19.301124, xcmsdb-1.0.3 [unpackaged],
taca [Sat, 25 Sep 2010 00:14:53 +0000 (00:14 +0000)]
+mailman-2.1.14, open-vm-tools-2010.09.19.301124, xcmsdb-1.0.3 [unpackaged],
 xlsclients-1.1.1, xmodmap-1.0.5.

3 years agoNote update of mail/mailman package to 2.1.12nb2.
taca [Fri, 24 Sep 2010 23:25:14 +0000 (23:25 +0000)]
Note update of mail/mailman package to 2.1.12nb2.

3 years agoAdd patches to fix XSS (CVE-2010-3089).
taca [Fri, 24 Sep 2010 23:24:31 +0000 (23:24 +0000)]
Add patches to fix XSS (CVE-2010-3089).

Bump PKGREVISION.

3 years agoNote PKGREVISION bump of web2c.
minskim [Fri, 24 Sep 2010 21:55:19 +0000 (21:55 +0000)]
Note PKGREVISION bump of web2c.

3 years agoResolve conflicts between web2c and tex-latex-bin-doc.
minskim [Fri, 24 Sep 2010 21:54:57 +0000 (21:54 +0000)]
Resolve conflicts between web2c and tex-latex-bin-doc.

3 years agoUpdate tex-collection-basic to 2010.
minskim [Fri, 24 Sep 2010 21:30:23 +0000 (21:30 +0000)]
Update tex-collection-basic to 2010.

- Updated dependencies.

3 years agoNote PKGREVISION bump of tex-xdvi.
minskim [Fri, 24 Sep 2010 21:26:50 +0000 (21:26 +0000)]
Note PKGREVISION bump of tex-xdvi.

3 years agoUpdate tex-xdvi to r18835.
minskim [Fri, 24 Sep 2010 21:26:28 +0000 (21:26 +0000)]
Update tex-xdvi to r18835.

- Add some useful translations for the mouse wheel (bug #1422928)

3 years agoUpdate DISTFILES of tex-metafont for TeX Live 2010. No functional change.
minskim [Fri, 24 Sep 2010 21:19:14 +0000 (21:19 +0000)]
Update DISTFILES of tex-metafont for TeX Live 2010.  No functional change.

3 years agoNote update of tex-luatex{,-doc}.
minskim [Fri, 24 Sep 2010 21:17:03 +0000 (21:17 +0000)]
Note update of tex-luatex{,-doc}.

3 years agoUpdate tex-luatex{,-doc} to 0.60.1.
minskim [Fri, 24 Sep 2010 21:16:27 +0000 (21:16 +0000)]
Update tex-luatex{,-doc} to 0.60.1.

- Added LuaTeX configuration file.

3 years agoNote update of tex-hyph-utf8{,-doc}.
minskim [Fri, 24 Sep 2010 21:10:14 +0000 (21:10 +0000)]
Note update of tex-hyph-utf8{,-doc}.

3 years agoUpdate tex-hyph-utf8{,-doc} to 2010.
minskim [Fri, 24 Sep 2010 21:09:27 +0000 (21:09 +0000)]
Update tex-hyph-utf8{,-doc} to 2010.

- LuaTeX configuration file added.
- Hyphenation patterns for many languages added.

3 years agoUpdated mail/roundcube to 0.4
pettai [Fri, 24 Sep 2010 20:57:38 +0000 (20:57 +0000)]
Updated mail/roundcube to 0.4

3 years agoNote update of tex-dvipdfmx{,-doc}.
minskim [Fri, 24 Sep 2010 20:56:21 +0000 (20:56 +0000)]
Note update of tex-dvipdfmx{,-doc}.

3 years agoUpdate tex-dvipdfmx{,-doc} to 2010.
minskim [Fri, 24 Sep 2010 20:55:51 +0000 (20:55 +0000)]
Update tex-dvipdfmx{,-doc} to 2010.

- The default version for output PDF files is 1.5.

3 years agoNote PKGREVISION bump of tex-dvipdfm.
minskim [Fri, 24 Sep 2010 20:48:46 +0000 (20:48 +0000)]
Note PKGREVISION bump of tex-dvipdfm.

3 years agoUpdate tex-dvipdfm{,-doc} to r19724.
minskim [Fri, 24 Sep 2010 20:48:15 +0000 (20:48 +0000)]
Update tex-dvipdfm{,-doc} to r19724.

- Font map files sync'ed with pdftex and dvips.

3 years agoUpdate DISTFILES of tex-apalike{,-doc} for TeX Live 2010.
minskim [Fri, 24 Sep 2010 20:42:04 +0000 (20:42 +0000)]
Update DISTFILES of tex-apalike{,-doc} for TeX Live 2010.
No functional change.

3 years agonote update of isc-dhcp4 (and siblings)
spz [Fri, 24 Sep 2010 20:31:44 +0000 (20:31 +0000)]
note update of isc-dhcp4 (and siblings)

3 years agoupdating the isc-dhcp packages to 4.1.1-P1
spz [Fri, 24 Sep 2010 20:29:28 +0000 (20:29 +0000)]
updating the isc-dhcp packages to 4.1.1-P1

Changelog:
      NEW FEATURES

ISC DHCP 4.1.x includes several new DHCPv6 features that were not included
in DHCP 4.0.x.  These include:

- Support for the rapid-commit option on the client side

- Prefix Delegation support

- IA_TA address support

- A basic DHCPv6 relay agent

- Basic and partial DHCPv6 leasequery support

There are a number of DHCPv6 limitations and features missing in this
release, which will be addressed in the future:

- Only Solaris, Linux, FreeBSD, NetBSD, and OpenBSD are supported.

- Only a single address is supported per IA.

- DHCPv6 includes human-readable text in status code messages. These
  should be configurable, and probably localized via gettext() or the
  like.

- The "host-identifier" option is limited to a simple token.

- The client and server can only operate DHCPv4 or DHCPv6 at a time,
  not both.  To use both protocols simultaneously, two instances of the
  relevant daemon are required, one with the '-6' command line option.

For information on how to install, configure and run this software, as
well as how to find documentation and report bugs, please consult the
README file.

ISC DHCP uses standard GNU configure for installation. Please review the
output of "./configure --help" to see what options are available.

The system has only been tested on Linux, FreeBSD, and Solaris, and may not
work on other platforms. Please report any problems and suggested fixes to
<dhcp-users@isc.org>.

                        Changes since 4.1.1

- A bug was fixed that could cause the DHCPv6 server to advertise/assign a
  previously allocated (active) lease to a client that has changed subnets,
  despite being on different shared networks.  Dynamic prefixes specifically
  allocated in shared networks also now are not offered if the client has
  moved.  [ISC-Bugs #21152]

! Accept a client id of length 0 while hashing.  Previously the server would
  exit if it attempted to hash a zero length client id, providing attackers
  with a simple denial of service attack.  [ISC-Bugs #21253]

                        Changes since 4.1.1rc1

- When using 'ignore client-updates;', the FQDN returned to the client
  is no longer truncated to one octet.

                        Changes since 4.1.1b3

- None.

Changes since 4.1.1b2

- Fix test in dhcp_interface_signal_handler to check that the inner handler
  has a signal_handler before calling it.

- Both host and subnet6 configuration groups are now included whether a
  fixed-address6 (DHCPv6) is in use or not.  Host scoped configuration takes
  precedence.  This fixes two bugs, one where host scoped configuration
  would not be included from a non-fixed-address6 host record, and the equal
  and opposite bug where subnet6 scoped configuration would not be used when
  over-riding values were not present in a matching fixed-address6 host
  configuration.

- ./configure now checks to ensure the intX_t and u_intX_t types are defined,
  correcting a compilation failure when using Sun's compiler.

- Modified the handling of a connection to avoid releasing the omapi io
  object for the connection while it is still in use.  One symptom from
  this error was a segfault when a failover secondary attempted to connect
  to the failover primary if their clocks were not synchronized.

Changes since 4.1.1b1

- Remove infinite loop in token_print_indent_concat().

- Memory leak in the load_balance_mine() function is fixed.  This would
  leak ~20-30 octets per DHCPDISCOVER packet while failover was in use
  and in normal state.

- Various compilation fixes have been included for the memory related
  DEBUG #defines in includes/site.h.

- Fixed Linux client script 'unary operator expected' errors with DHCPv6.

- Fixed setting hostname in Linux hosts that require hostname argument
  to be double-quoted.  Also allow server-provided hostname to
  override hostnames 'localhost' and '(none)'.

- Added client support for setting interface MTU and metric, thanks to
  Roy "UberLord" Marples <roy@marples.name>.

- Fixed failover reconnection retry code to continue to retry to reconnect
  rather than restarting the listener.

- Compilation on Solaris with USE_SOCKETS defined in includes/site.h has
  been repaired.  Other USE_ overrides should work better.

- A check for the local flavor of IFNAMSIZ had a broken 'else' condition,
  that probably still resulted in the correct behaviour (but wouldn't use
  a larger defined value provided by the host OS).

- Fixed a bug where an OMAPI socket disconnection message would not result
  in scheduling a failover reconnection, if the link had not negotiated a
  failover connect yet (e.g.: connection refused, asynch socket connect()
  timeouts).

- A bug was fixed that caused the 'conflict-done' state to fail to be parsed
  in failover state records.

! A stack overflow vulnerability was fixed in dhclient that could allow
  remote attackers to execute arbitrary commands as root on the system,
  or simply terminate the client, by providing an over-long subnet-mask
  option.  CERT VU#410676 - CVE-2009-0692

- Versions 3.0.x syntax with multiple name->code option definitions is now
  supported.  Note that, similarly to 3.0.x, for by-code lookups only the
  last option definition is used.

- Fixed a bug where a time difference of greater than 60 seconds between a
  failover pair could cause the primary to crash on contact with the
  secondary.  Thanks to a patch from Steinar Haug.

- Don't look for IPv6 interfaces on Linux when running in DHCPv4 mode.
  Thanks to patches from Matthew Newton and David Cantrell.

- Secondary servers in a failover pair will now perform ddns removals if
  they had performed ddns updates on a lease that is expiring, or was
  released through the primary.  As part of the same fix, stale binding scopes
  will now be removed if a change in identity of a lease's active client is
  detected, rather than simply if a lease is noticed to have expired (which it
  may have expired without a failover server noticing in some situations).

- A patch supplied by David Cantrell at RedHat was applied that detects
  invalid calling parameters given to the ns_name_ntop() function.
  Specifically, it detects if the caller passed a pointer and size pair
  that causes the pointer to integer-wrap past zero.

! Fixed a fenceposting bug when a client had two host records configured,
  one using 'uid' and the other using 'hardware ethernet'.  CVE-2009-1892

Changes since 4.1.0

- Validate the argument to the -p option.

- The notorious 'option <unknown> ... larger than buffer' log line,
  which is seen in some malformed DHCP client packets, was modified.
  It now logs the universe name, and does not log the length values
  (which are bogus corruption read from the packet anyway).  It also
  carries a hopefully more useful explanation.

- A bug was fixed that caused the server not to answer some valid Solicit
  and Request packets, if the dynamic range covering any requested addresses
  had been deleted from configuration.

- Suppress spurious warnings from configure about --datarootdir

- Update the code to deal with GCC 4.3.  This included two sets of changes.
  The first is to the configuration files to include the use of
  AC_USE_SYSTEM_EXTENSIONS.  The second is to deal with return values that
  were being ignored.

- The db-time-format option was documented in manpages.

- Using reserved leases no longer results in 'lease with binding state
  free not on its queue' error messages, thanks to a patch from Frode
  Nordahl.

- DDNS removal routines were updated so that the DHCID is not removed until
  the client has been deprived of all A and AAAA records (not only the last
  one of either of those).  This resolves a bug where dual stack clients
  would not be able to regain their names after either expiration event.

- Fix a build error in dhcrelay, using older versions of gcc with
  dhcpv6 disabled.

- Two uninitialized stack structures are now memset to zero, thanks to
  patch from David Cantrell at Red Hat.

- Fixed a cosmetic bug where pretty-printing valid domain-search options would
  result in an erroneous error log message ('garbage in format string').

- A bug in DLPI packet transmission (Solaris, HP/UX) that caused the server
  to stop receiving packets is fixed.  The same fix also means that the MAC
  address will no longer appear 'bogus' on DLPI-based systems.

- A bug in select handling was discovered where the results of one select()
  call were discarded, causing the server to process the next select() call
  and use more system calls than required.  This has been repaired - the
  sockets will be handled after the first return from select(), resulting in
  fewer system calls.

- The update-conflict-detection feature would leave an FQDN updated without
  a DHCID (still currently implemented as a TXT RR).  This would cause later
  expiration or release events to fail to remove the domain name.  The feature
  now also inserts the client's up to date DHCID record, so records may safely
  be removed at expiration or release time.  Thanks to a patch submitted by
  Christof Chen.

3 years agoUpdate DISTFILES for tex-amsfonts{,-doc} for TeX Live 2010.
minskim [Fri, 24 Sep 2010 20:28:58 +0000 (20:28 +0000)]
Update DISTFILES for tex-amsfonts{,-doc} for TeX Live 2010.
No functional change.

3 years agoNote udpate of tex-amscls{,-doc}.
minskim [Fri, 24 Sep 2010 20:21:44 +0000 (20:21 +0000)]
Note udpate of tex-amscls{,-doc}.

3 years agoUpdate tex-amscls{,-doc} to 2010.
minskim [Fri, 24 Sep 2010 20:21:00 +0000 (20:21 +0000)]
Update tex-amscls{,-doc} to 2010.

Improved DESCR.

3 years agoUpdated filesystems/tahoe-lafs to 1.8.0
gdt [Fri, 24 Sep 2010 18:21:11 +0000 (18:21 +0000)]
Updated filesystems/tahoe-lafs to 1.8.0

3 years agoUpdate to 1.8.0.
gdt [Fri, 24 Sep 2010 18:20:59 +0000 (18:20 +0000)]
Update to 1.8.0.

* Release 1.8.0 (2010-09-23)

** New Features

 - A completely new downloader which improves performance and
   robustness of immutable-file downloads. It uses the fastest K
   servers to download the data in K-way parallel. It automatically
   fails over to alternate servers if servers fail in mid-download. It
   allows seeking to arbitrary locations in the file (the previous
   downloader which would only read the entire file sequentially from
   beginning to end). It minimizes unnecessary round trips and
   unnecessary bytes transferred to improve performance. It sends
   requests to fewer servers to reduce the load on servers (the
   previous one would send a small request to every server for every
   download) (#287, #288, #448, #798, #800, #990, #1170, #1191)

 - Non-ASCII command-line arguments and non-ASCII outputs now work on
   Windows. In addition, the command-line tool now works on 64-bit
   Windows. (#1074)

** Bugfixes and Improvements

 - Document and clean up the command-line options for specifying the
   node's base directory. (#188, #706, #715, #772, #1108)
 - The default node directory for Windows is ".tahoe" in the user's
   home directory, the same as on other platforms. (#890)
 - Fix a case in which full cap URIs could be logged. (#685, #1155)
 - Fix bug in WUI in Python 2.5 when the system clock is set back to
   1969. Now you can use Tahoe-LAFS with Python 2.5 and set your
   system clock to 1969 and still use the WUI. (#1055)
 - Many improvements in code organization, tests, logging,
   documentation, and packaging. (#983, #1074, #1108, #1127, #1129,
   #1131, #1166, #1175)

3 years agoUpdated security/py-cryptopp to 0.5.25
gdt [Fri, 24 Sep 2010 18:10:58 +0000 (18:10 +0000)]
Updated security/py-cryptopp to 0.5.25

3 years agoUpdate to 0.5.25. Add patch to not install odd extraversion.h file.
gdt [Fri, 24 Sep 2010 18:10:46 +0000 (18:10 +0000)]
Update to 0.5.25.   Add patch to not install odd extraversion.h file.

2010-09-20 -- pycryptopp v0.5.25

    * make setup backwards-compatible to Python 2.4
    * fix incompatibilities between setup script and older versions of darcsver
    * don't attempt to compile Mac OS X extended attribute files (this fixes the build breaking)
    * include a version number of the specific version of Crypto++ in extraversion.h
    * small changes to docs

2010-09-18 -- pycryptopp v0.5.20

    * fix bugs in assembly implementation of SHA-256 from Crypto++
    * fix it to compile on *BSD (#39)
    * improve doc strings
    * add a quick start-up-self-test of SHA256 (#43)
    * execute the quick start-up-self-tests of AES and SHA256 on module import

3 years agoimported this in the wrong place, oops.
chs [Fri, 24 Sep 2010 17:11:45 +0000 (17:11 +0000)]
imported this in the wrong place, oops.

3 years agorestore qt3 to modules list, suse 10.0 still needs it.
chs [Fri, 24 Sep 2010 17:08:35 +0000 (17:08 +0000)]
restore qt3 to modules list, suse 10.0 still needs it.

3 years agofix modules list.
chs [Fri, 24 Sep 2010 17:04:43 +0000 (17:04 +0000)]
fix modules list.

3 years agoUpdate DISTFILES of tex-ukrhyph{,-doc} for TeX Live 2010. No
minskim [Fri, 24 Sep 2010 17:04:08 +0000 (17:04 +0000)]
Update DISTFILES of tex-ukrhyph{,-doc} for TeX Live 2010.  No
fuctional change.

3 years agoNote update of tex-carlisle{,-doc}.
minskim [Fri, 24 Sep 2010 16:55:15 +0000 (16:55 +0000)]
Note update of tex-carlisle{,-doc}.

3 years agoUpdate tex-carlisle{,-doc} to 2010.
minskim [Fri, 24 Sep 2010 16:54:43 +0000 (16:54 +0000)]
Update tex-carlisle{,-doc} to 2010.

Changes in comments only.

3 years agoSync tex-printlen with tex-printlen-doc.
minskim [Fri, 24 Sep 2010 16:46:56 +0000 (16:46 +0000)]
Sync tex-printlen with tex-printlen-doc.

3 years agoAdd tex-printlen-doc.
minskim [Fri, 24 Sep 2010 16:45:20 +0000 (16:45 +0000)]
Add tex-printlen-doc.

3 years agoMerge from vendor branch TNF:
minskim [Fri, 24 Sep 2010 16:44:31 +0000 (16:44 +0000)]
Merge from vendor branch TNF:
Import tex-printlen-doc-1.1a as print/tex-printlen-doc.

This is documentation for tex-printlen.

3 years agoImport tex-printlen-doc-1.1a as print/tex-printlen-doc. TNF
minskim [Fri, 24 Sep 2010 16:44:31 +0000 (16:44 +0000)]
Import tex-printlen-doc-1.1a as print/tex-printlen-doc.

This is documentation for tex-printlen.

3 years agoNote PKGREVISION bump of tex-placeins-doc.
minskim [Fri, 24 Sep 2010 16:40:32 +0000 (16:40 +0000)]
Note PKGREVISION bump of tex-placeins-doc.

3 years agoUpdate tex-placeins{,-doc} to r19848.
minskim [Fri, 24 Sep 2010 16:39:59 +0000 (16:39 +0000)]
Update tex-placeins{,-doc} to r19848.

.pdf and .tex documentations were added.