Installer import into contrib (real import this time)
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / sysutils / dfuife_qt / Makefile
1 # New ports collection makefile for:    dfuife_qt
2 # Date created:                 Oct 19, 2004
3 # Whom:                         Chris Pressey <cpressey@catseye.mine.nu>
4
5 PORTNAME=       dfuife_qt
6 PORTVERSION=    1.2
7 INTERNAL=       YES
8 CATEGORIES=     sysutils
9 DISTNAME=       ${PORTNAME}-${PORTVERSION}
10 WRKSRC=         work/qt
11
12 LIB_DEPENDS=    dfui.4:${PORTSDIR}/sysutils/libdfui
13
14 USE_QT_VER=     3
15
16 MAINTAINER=     cpressey@catseye.mine.nu
17 COMMENT=        DFUI Qt frontend
18
19 PLIST_FILES=    sbin/dfuife_qt
20
21 do-fetch:
22         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
23                 ${ECHO_MSG};                                                    \
24                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
25                 ${ECHO_MSG};                                                    \
26                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
27                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
28                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
29                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
30                 ${ECHO_MSG} "to create these distfiles.";                       \
31                 false;                                                          \
32         fi
33
34 do-install:
35         ${INSTALL_PROGRAM} -o root -g wheel -m 555 ${WRKSRC}/dfuife_qt ${LOCALBASE}/sbin
36
37 OSTYPE!=sysctl -n kern.ostype
38
39 .if ${OSTYPE} == "FreeBSD"
40 .include <bsd.port.mk>
41 .endif
42
43 .if ${OSTYPE} == "DragonFly"
44 .include <bsd.dfport.mk>
45 .endif
46