openssl: Update version/date in the manual pages.
[dragonfly.git] / UPDATING
1 # Updating Information for DragonFly users.
2 #
3 #
4 # This file should warn you of any pitfalls which you might need to work around
5 # when trying to update your DragonFly system.  The information below is
6 # in reverse-time order, with the latest information at the top.
7 #
8 # If you discover any problem, please contact the bugs@lists.dragonflybsd.org
9 # mailing list with the details.
10
11 +-----------------------------------------------------------------------+
12 +         UPGRADING DRAGONFLY FROM 3.8 TO LATER VERSIONS                +
13 +-----------------------------------------------------------------------+
14
15 SMP and DEVICE_POLLING OPTIONS MADE UNKNOWN
16 -------------------------------------------
17
18 DEVICE_POLLING was replaced by IFPOLL_ENABLE and the former SMP code is
19 the default now (even on single-core systems), both for, like, 21 months.
20 We kept the options around as no-ops as a convenience, to allow people
21 using the same config for the then current release and the then current
22 master. That period is now over, so any configs still having those
23 options have to be adjusted.
24
25 SYSVIPC SYSCALLS MADE NON-OPTIONAL
26 ----------------------------------
27
28 The code related to the SYSVMSG, SYSVSEM and SYSVSHM kernel options is
29 now compiled in by default. The options are no-ops for now.
30
31 DEFAULT DRIVER CHANGED FOR LSI "THUNDERBOLT" SERIES RAID CONTROLLERS
32 --------------------------------------------------------------------
33
34 The default driver for those controllers is now mrsas(4) due to reports
35 of file system corruption using the mfi(4) driver. The whole issue (and
36 how to deal with potential problems when switching) was explained here:
37
38 http://lists.dragonflybsd.org/pipermail/users/2014-July/128703.html
39
40 A tunable is provided for letting those controllers still attach via
41 the mfi(4) driver, hw.mrsas.mfi_enable (see mrsas(4) manual page).
42
43 OLDER NETWORK DRIVERS MOVED TO I386 ONLY
44 ----------------------------------------
45
46 The following drivers have been made i386 only: ed(4), sr(4), ng_sync_ar
47 and ng_sync_sr. ed(4) used to be in X86_64_GENERIC, so it has to be
48 removed in kernel configs derived from X86_64_GENERIC.
49
50 +-----------------------------------------------------------------------+
51 +         UPGRADING DRAGONFLY FROM 3.6 TO LATER VERSIONS                +
52 +-----------------------------------------------------------------------+
53
54 UPDATE FROM MOST RECENT 3.6
55 ---------------------------
56
57 Versions of 3.6 built before June 25th have a bug where installworld might 
58 crash during installation of the new initrd.  Upgrade to the latest version
59 of 3.6 before updating to 3.8 or later.
60
61 ATM, IPX, NCP AND NWFS SUPPORT DROPPED
62 --------------------------------------
63
64 Support for the IPX and NCP network protocols and for mouting NetWare
65 file systems has been dropped. Dito for ATM protocol support.
66
67 INITRD IMAGES NOW INSTALLED BY DEFAULT
68 --------------------------------------
69
70 An initial ramdisk image is now installed in /boot/kernel/initrd.img.gz
71
72 Older images installed under the file name of initrd.img will be removed
73 automatically by the make upgrade process.
74
75 USB4BSD IS NOW THE DEFAULT USB STACK
76 ------------------------------------
77
78 To get back to the old stack, put "WANT_OLDUSB=yes" in /etc/make.conf and
79 replace "device usb" with "device oldusb" in the kernel configuration.
80
81 MORE ISA SUPPORT DROPPED
82 ------------------------
83
84 ISA support has been dropped from the following drivers: adv(4), an(4),
85 ar(4), cs(4), digi(4), ed(4), ep(4), ex(4), fe(4), lnc(4), sbni(4),
86 si(4), sn(4), and stg(4).
87
88 +-----------------------------------------------------------------------+
89 +         UPGRADING DRAGONFLY FROM 3.4 TO LATER VERSIONS                +
90 +-----------------------------------------------------------------------+
91
92 ABI CHANGE
93 ----------
94
95 Installed third-party software (dports) will have to be rebuilt after upgrade,
96 or reinstalled from binary packages.
97
98 UPDATING FROM 3.4 TO 3.6
99 ------------------------
100
101 This only applies for this specific upgrade due to locale changes; it is 
102 not needed for upgrades after 3.6.  Please update in this order:
103
104 make buildworld
105 make buildkernel
106 make installworld
107 make installkernel
108 *reboot*
109 make upgrade
110
111 See this mailing list post for details:
112 http://lists.dragonflybsd.org/pipermail/users/2013-September/090163.html
113
114 CYRIX OPTIONS REMOVED
115 ---------------------
116
117 The following Cyrix related options have been removed: CPU_BTB_EN,
118 CPU_CYRIX_NO_LOCK, CPU_DIRECT_MAPPED_CACHE, CPU_DISABLE_5X86_LSSER,
119 CPU_FASTER_5X86_FPU, CPU_IORT, CPU_LOOP_EN, CPU_RSTK_EN, CPU_SUSP_HLT,
120 CYRIX_CACHE_WORKS, and CYRIX_CACHE_REALLY_WORKS
121
122 ISA SUPPORT REMOVED FROM RP(4)
123 ------------------------------
124
125 ISA support has been removed from the rp(4) driver. It is now PCI only.
126
127 +-----------------------------------------------------------------------+
128 +         UPGRADING DRAGONFLY FROM 3.2 TO LATER VERSIONS                +
129 +-----------------------------------------------------------------------+
130
131 COMPAT_SUNOS OPTION REMOVED
132 ---------------------------
133
134 The COMPAT_SUNOS option has been removed. It was meant to provide binary
135 compatibility with SunOS 4.x for the sparc32 port of 4.4BSD.
136
137 ISA SOUND CARD SUPPORT REMOVED
138 ------------------------------
139
140 The following modules have been removed (all for ISA sound cards):
141 snd_ad1816.ko, snd_ess.ko, snd_mss.ko, snd_sb8.ko, snd_sb16.ko, snd_sbc.ko
142
143 GCC 4.7
144 -------
145
146 DragonFly has switched base compilers.  GCC 4.7 is now the default
147 compiler and GCC 4.4 is the alternative compiler.  The "NO_GCC47" make
148 variable ceases to work now.
149
150 Users who wish to build only GCC 4.7 have to use NO_GCC44 in the
151 /etc/make.conf to prohibit GCC 4.4 from building.  However, using it is
152 highly discouraged.  There are a few packages in pkgsrc that do not build
153 with GCC 4.7 and the new "DPorts" system uses GCC 4.4 by default.  At
154 this time, it is recommended to keep both compilers on the base system.
155
156 SMP OPTION REMOVED
157 ------------------
158
159 The SMP kernel option has been made a no-op. All kernels now feature SMP
160 support. If you have 'options SMP' in your kernel config, you can as well
161 remove it.
162
163 DEVICE_POLLING OPTION REPLACED BY IFPOLL_ENABLE OPTION, KTR_POLLING REMOVED
164 ---------------------------------------------------------------------------
165
166 The DEVICE_POLLING kernel option has been made a no-op and it has been
167 replaced by IFPOLL_ENABLE.  If you have 'options DEVICE_POLLING' in your
168 kernel config, you need to change it to IFPOLL_ENABLE.
169
170 Also, the KTR_POLLING kernel option has been removed, so it must be
171 removed from kernel configs that have it.
172
173 BUSLOGIC, CYCLADES AND STALLION ISA SUPPORT REMOVED
174 ---------------------------------------------------
175
176 The bt(4) driver for Buslogic SCSI adapters has been made PCI only. ISA
177 cards will no longer be detected.
178
179 The same has been done for Stallion multiport serial controllers. stli(4)
180 has been completely removed (along with the stlload(8) and stlstty(8)
181 utilities) and stl(4) was changed to support only PCI cards. Similarly,
182 ISA support was removed from cy(4) too. All these drivers are i386 only.
183
184 COMPAT_OLDISA OPTION GONE
185 -------------------------
186
187 The i386 specific COMPAT_OLDISA kernel option has been removed, since
188 nothing needs it anymore.
189
190 +-----------------------------------------------------------------------+
191 +         UPGRADING DRAGONFLY FROM 3.0 TO LATER VERSIONS                +
192 +-----------------------------------------------------------------------+
193
194 APIC_IO OPTION REMOVED
195 ----------------------
196
197 The APIC_IO kernel option is no longer accepted after having been without
198 effect for a while. The hw.ioapic_enable tunable now serves its purpose.
199 If you have 'options APIC_IO' in your kernel config, you'll have to
200 remove it.
201
202 WATCHDOG_ENABLE & HW_WDOG OPTIONS REMOVED
203 -----------------------------------------
204
205 The wdog framework is now compiled into our kernels by default, so the
206 options are no longer needed.
207
208 DOSCMD(1) REMOVED
209 -----------------
210
211 doscmd(1) has been removed. It was i386 only. The doscmd(1) specific
212 NO_X make.conf option was removed too.
213
214 GCC 4.7
215 -------
216
217 GCC 4.7 has been brought in and replaces GCC 4.1 as DragonFly's non-
218 default compiler in base (default is still GCC 4.4).
219
220 Users who wish to build only GCC 4.4 have to replace NO_GCC41 with
221 NO_GCC47 in /etc/make.conf.
222
223 USB4BSD
224 -------
225
226 A new USB stack (from FreeBSD) has been brought in. The following
227 modules have been ported so far: usb, uhci, ohci, ehci, xhci, umass,
228 usfs, uether, if_axe, if_udav, ukbd, ums, uep, uhid, usb_quirk,
229 and uaudio.
230
231 It is not yet the default. To activate it, WANT_USB4BSD=yes has to
232 be put in make.conf and device "usb4bsd" (quotes needed) has to
233 replace device usb in the kernel config. After that, a full
234 build/install/upgrade cycle is needed.
235
236 Note that this is experimental and incomplete, but we are interested
237 in hearing about issues with it, of course.
238
239 ISA SUPPORT REMOVED FROM AIC-6260/6360 DRIVER
240 ---------------------------------------------
241
242 ISA adapter support was dropped from the aic(4) driver.
243
244 +-----------------------------------------------------------------------+
245 +         UPGRADING DRAGONFLY FROM 2.10 TO LATER VERSIONS               +
246 +-----------------------------------------------------------------------+
247
248 SEVERAL ISA DRIVERS REMOVED
249 ---------------------------
250
251 The following ISA only drivers have been removed along with a couple of
252 associated userland tools:
253
254 aha(4)
255 asc(4) & sasc(1)
256 ctx
257 dgb(4)
258 el(4)
259 gpib
260 gsc(4) & sgsc(1)
261 ie(4)
262 labpc(4)
263 le(4)
264 mse(4)
265 rc(4)
266 rdp(4)
267 spigot
268 tw(4) & xten(1) & xtend(8)
269 wl(4) & wlconfig(8)
270 wt(4)
271
272 Note that two of these drivers (aha(4) and ie(4)) are in our GENERIC
273 config and one (aha(4)) is in our X86_64_GENERIC kernel configuration
274 file.
275
276 If buildkernel complains about any of these drivers, just remove them
277 from your kernel configuration.
278
279 BINUTILS 2.20
280 -------------
281 Binutils 2.20 has been removed in favor of Binutils 2.22.  The accepted
282 values of BINUTILSVERS are now binutils221 and binutils222 (default).
283
284 BUILDWORLD/-KERNEL PARALLELIZATION WORK
285 ---------------------------------------
286 Due to changes in the way we build with more than one make job, you
287 will have to update install(1) and mkdir(1) prior to buildworld if you
288 want to build with 'make -j':
289
290 cd /usr/src/usr.bin/xinstall; make; make install; make clean
291 cd /usr/src/bin/mkdir; make; make install; make clean
292
293 DMA(8) UPGRADE
294 --------------
295 dma(8) has been upgraded to v0.7 which no longer supports the
296 /etc/dma/virtusertable. Some of its functionality has been replaced
297 with the MASQUERADE keyword and the EMAIL environment variable (see
298 the dma(8) manual page).
299
300 +-----------------------------------------------------------------------+
301 +         UPGRADING DRAGONFLY FROM 2.8 TO LATER VERSIONS                +
302 +-----------------------------------------------------------------------+
303
304 GCC 4.4 & BINUTILS 2.21
305 -----------------------
306
307 GCC 4.4 has been made DragonFly's default compiler and Binutils 2.21 has
308 been made DragonFly's default Binutils.
309
310 That means that any settings that set CCVER to 'gcc44' are not needed
311 anymore. Instead, CCVER can be set to 'gcc41' to go back to using
312 GCC 4.1.
313
314 It also means that 'binutils221' as a value for BINUTILSVER has no
315 effect anymore. 2.17 has been removed and 'binutils220' is available
316 as an option.
317
318 The NO_GCC44 option has been removed and will not affect the build
319 anymore. There is now a NO_GCC41 option that will prevent GCC 4.1 from
320 building in a similar fashion.
321
322 Note that you must do a full buildworld/buildkernel for upgrading.
323
324 pkg_radd settings
325 -----------------
326
327 The config file for pkg_radd has moved from /etc/settings.conf to 
328 /etc/pkg_radd.conf.  Save the contents of settings.conf before upgrading
329 if this is needed.  This warning only applies if /etc/settings.conf 
330 exists.  pkg_radd will continue to work with defaults.
331
332 +-----------------------------------------------------------------------+
333 +         20100927                                                      +
334 +         UPGRADING DRAGONFLY FROM 2.6 to 2.8 or HEAD                   +
335 +-----------------------------------------------------------------------+
336
337 OpenSSL
338 --------
339
340 OpenSSL has been upgraded, and SHLIB_MAJOR was bumped for libssh and libcrypto.
341 This shouldn't break any 3rd-party software, but you'll need to recompile your
342 3rd-party software if you want it to link against the new version of OpenSSL.
343
344 Loader
345 -------
346
347 A new loader (dloader) has been added which better handles booting from
348 multiple kernel/module versions.
349
350 To upgrade (Only for this upgrade, for post 2.8 upgrades see GENERAL below)
351
352         cd /usr/src
353         make buildworld
354         make installworld
355         make upgrade
356         make buildkernel KERNCONF=<KERNELNAME>
357         make installkernel KERNCONF=<KERNELNAME>
358
359 Note that you must installworld and run the 'upgrade' target before
360 installing the new kernel.
361
362 BIND
363 -----
364
365 BIND has been removed from the base system.  The ldns and drill tools have 
366 been added for basic functionality.  Use 'drill' where you would normally 
367 use nslookup or dig, or install BIND from pkgsrc.  It's available as 
368 net/bind95, net/bind96, or net/bind97 as of this writing.
369
370 This only affects older systems upgrading to 2.8.  New 2.8+ installs 
371 include BIND as a pkgsrc package.
372
373 +-----------------------------------------------------------------------+
374 +         UPGRADING DRAGONFLY ON AN EXISTING DRAGONFLY SYSTEM           +
375 +                               GENERAL                                 +
376 +-----------------------------------------------------------------------+
377
378 Instructions on how to obtain and maintain DragonFly source code using git
379 are in the development(7) manual page.
380
381 To upgrade a DragonFly system from sources you run the following sequence:
382
383         cd /usr/src
384         make buildworld
385         make buildkernel KERNCONF=<KERNELNAME>
386         make installkernel KERNCONF=<KERNELNAME>
387         make installworld
388
389 You will also want to run the 'upgrade' target to upgrade your /etc and the
390 rest of your system.  The upgrade target is aware of stale files created by
391 older DragonFly installations and should delete them automatically.
392
393         make upgrade
394
395 See the build(7) manual page for further information.
396
397 Once you've done a full build of the world and kernel you can do incremental
398 upgrades of either by using the 'quickworld' and 'quickkernel' targets
399 instead of 'buildworld' and 'buildkernel'.  If you have any problems with
400 the quick targets, try updating your repo first, and then a full buildworld
401 and buildkernel as shown above, before asking for help.
402
403 +-----------------------------------------------------------------------+
404 +         UPGRADING FROM DRAGONFLY <= 2.0 TO DRAGONFLY >= 2.1           +
405 +-----------------------------------------------------------------------+
406
407 In 2.1 kernel and modules has moved to boot directory.  For most cases
408 this is handled automatically by 'make upgrade'.  A few cases needs manual
409 intervention:
410
411  * When installing a kernel without first doing a make buildworld,
412    installworld and upgrade to the same DESTDIR as kernel:
413    make DESTDIR/boot directory and move kernel and modules into this boot
414    directory; also move kernel.old and modules.old.
415    Typical example is vkernel(7), use (no modules used):
416
417         cd /var/vkernel
418         mkdir boot
419         chflags noschg kernel
420         mv kernel kernel.old boot
421         chflags schg boot/kernel
422         
423  * When using a boot-only partition, /boot/loader.rc needs to be edited:
424    delete occurrences of '/boot/'.
425    These occurences can normally be deleted in any case, see loader(8).
426
427 +-----------------------------------------------------------------------+
428 +         UPGRADING FROM DRAGONFLY <= 1.8 TO DRAGONFLY >= 1.9           +
429 +-----------------------------------------------------------------------+
430
431 In 1.9 major changes to the disk management infrastructure have taken
432 place.  make upgrade may not catch all of your disk devices in /dev,
433 so after upgrading be sure to cd /dev; ./MAKEDEV <blah> where <blah>
434 are all of your disk devices.  HOWEVER, from late 2.3 on we run devfs
435 and MAKEDEV no longer exists.
436
437 The biggest changes in 1.9 are:
438
439 (1) That whole-slice devices such as da0s1 no longer share the same device
440     id as partition c devices such as da0s1c.
441
442 (2) The whole-disk device (e.g. da0) is full raw access to the disk,
443     with no snooping or reserved sectors.  Consequently you cannot run
444     disklabel on this device.  Instead you must run disklabel on a
445     whole-slice device.
446
447 (3) The 'compatibility' partitions now use slice 0 in the device name,
448     so instead of da0a you must specify da0s0a.  Also, as per (1) above,
449     accessing the disklabel for the compatibility partitions must be
450     done via slice 0 (da0s0).
451
452 (4) Many device drivers that used to fake up labels, such as CD, ACD, VN,
453     and CCD now run through the disk management layer and are assigned
454     real disk management devices.   VN and CCD in particular do not usually
455     use a MBR and disklabels must be accessed through the compatibility
456     slice 0.  Your /etc/ccd.conf file still specifies 'ccd0', though, you
457     don't name it 'ccd0s0' in the config file.
458
459 Generally speaking, you have to get used to running fdisk and disklabel on
460 the correctly specified device names.  A lot of the wiggle, such as running
461 disklabel on a partition, has been removed.
462
463 +-----------------------------------------------------------------------+
464 +         UPGRADING FROM OLDER VERSIONS OF DRAGONFLY OR FREEBSD         +
465 +-----------------------------------------------------------------------+
466
467 > Kerberos IV
468 -------------
469
470 Kerberos IV (eBones) was removed from the tree, please consider moving to
471 Kerberos 5 (Heimdal).
472
473 > Package Management System
474 ---------------------------
475
476 Starting with the 1.4 release, DragonFly uses NetBSD's pkgsrc package
477 management system.  The necessary tools to build and maintain packages
478 are provided in /usr/pkg/bin and /usr/pkg/sbin.  Make sure that these
479 directories are in your PATH variable.
480
481 In order to obtain a reasonably current snapshot of the pkgsrc tree, use
482 the tarball from NetBSD:
483
484         fetch -o /tmp/pkgsrc.tar.gz ftp://ftp.NetBSD.org/pub/NetBSD/packages/pkgsrc.tar.gz
485         cd /usr; tar -xzf /tmp/pkgsrc.tar.gz; chown -R root:wheel pkgsrc
486
487 This tree can then be kept up to date with cvs update:
488
489         cd /usr/pkgsrc; cvs up
490
491 NOTE! If you upgraded from a pre-1.4 system to 1.4 or later, you need to
492 build and install the pkgsrc bootstrap manually:
493
494         cd /usr/pkgsrc/bootstrap
495         ./bootstrap --pkgdbdir /var/db/pkg --prefix /usr/pkg
496
497 +-----------------------------------------------------------------------+
498 +         UPGRADING DRAGONFLY ON AN EXISTING DRAGONFLY SYSTEM           +
499 +         UPDATING FROM PRE-1.2 SYSTEMS OR FreeBSD 4.x TO               +
500 +         DRAGONFLY 1.3+ (EITHER PREVIEW or HEAD)                       +
501 +-----------------------------------------------------------------------+
502
503 The compatibility shims for the build environment have been removed, you
504 have to update to DragonFly 1.2 release branch first.
505
506 The default PAM configuration has moved from /etc/pam.conf to /etc/pam.d/.
507 The existing configuration can be converted using /etc/pam.d/convert.sh.
508 Entries in /etc/pam.d/ override entries in /etc/pam.conf. In addition
509 the pam_skey.so module was retired, you have to remove it manually from
510 your configuration, when you convert it.
511
512 > Required user and group IDs when upgrading from either FreeBSD or DragonFly
513 ---------------------
514
515 The following users may be missing from your password file.  Use vipw and
516 add any that are missing:
517
518 smmsp:*:25:25::0:0:Sendmail Submission User:/var/spool/clientmqueue:/sbin/nologin
519 _pflogd:*:64:64::0:0:pflogd privsep user:/var/empty:/sbin/nologin
520
521 The following groups may be missing from your group file.  Use vi /etc/group
522 and add any that are missing:
523
524 smmsp:*:25:
525 authpf:*:63:
526 _pflogd:*:64:
527
528
529 > Upgrading to DragonFly from FreeBSD
530 ---------------------
531
532 You can build the DragonFly world and DragonFly kernels on a FreeBSD-4.x or
533 FreeBSD-5.x machine and then install DragonFly over FreeBSD, replacing
534 FreeBSD.  Note that the DragonFly buildworld target does not try to reuse
535 make depend information, it starts from scratch, so no pre-cleaning of the
536 object hierarchy is necessary.
537
538         # get the CVS repository (it is placed in /home/dcvs, 500MB).
539         # Please use the -h option and a mirror site to pull the 
540         # initial repository, but feel free to use the main repository
541         # machine to pull updates.
542         cvsup /usr/share/examples/cvsup/DragonFly-cvs-supfile
543         # install the source from the CVS hierarchy (remove preexisting
544         # FreeBSD src first) (500MB)
545         cd /usr
546         rm -rf src
547         cvs -R -d /home/dcvs checkout -P src
548
549         # build it (500MB used in /usr/obj)
550         #
551         cd /usr/src
552         make buildworld
553         make buildkernel KERNCONF=<KERNELNAME>
554
555 Once you have built DragonFly you have to install it over FreeBSD.  Since
556 DragonFly does not track changes made by FreeBSD to its include file 
557 hierarchy and include file pollution can cause all sorts of unexpected
558 compilation issues to come up, it is best to wipe your include hierarchy
559 prior to installing DragonFly.  Note that you should not wipe any installed
560 FreeBSD header files or binaries until after you have successfully completed
561 the build steps above.
562
563         rm -rf /usr/include
564         mkdir /usr/include
565         make installkernel KERNCONF=<KERNELNAME>
566         make installworld
567
568 Then you need to upgrade your system.  DragonFly's 'make upgrade' target 
569 will unconditionally upgrade the /etc files that sysops do not usually
570 mess around with, such as the files in /etc/rc.d.  It will also remove any
571 obsolete files such as utilities and manpages that have been removed from
572 the system since the version you're coming from.  If you are unsure we 
573 recommend that you make a backup of at least your /etc before applying
574 this step.  Note that DragonFly's RC system is basically RCNG from
575 FreeBSD-5, but there are some differences in the contents of the RC files.
576
577         make upgrade
578
579 NOTE! Never do a 'make upgrade' before 'make installworld' has been run.
580 Doing so might leave your system in an unusable state.
581
582 Finally we recommend that you do an 'ls -lta BLAH' for /bin, /sbin, /usr/bin,
583 /usr/bin, and /usr/lib, and remove any stale files that you find.  Please
584 report these files to the DragonFly developers so that they can be added to
585 the 'upgrade' target.
586