Raise WARNS in secure/ as high as possible and fix some resulting warnings.
[dragonfly.git] / secure / usr.bin / sftp / Makefile
1 # $FreeBSD: src/secure/usr.bin/sftp/Makefile,v 1.1.2.3 2002/07/03 22:20:30 des Exp $
2 # $DragonFly: src/secure/usr.bin/sftp/Makefile,v 1.5 2008/09/28 03:19:46 pavalos Exp $
3
4 PROG=   sftp
5 SRCS=   sftp.c sftp-client.c sftp-common.c sftp-glob.c roaming_dummy.c
6 WARNS?= 2
7
8 # Portability layer
9 SRCS+=  fmt_scaled.c
10
11 DPADD+= ${LIBEDIT}
12 LDADD+= -ledit
13
14 .include "../../Makefile.ssh.common"
15 .include <bsd.prog.mk>
16
17 .PATH:  ${SSHDIR}/openbsd-compat