Merge from vendor branch NETGRAPH:
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-app / Makefile
1 # New ports collection makefile for:    lua50-app
2 # Date created:                         23 Feb 2005
3 # Whom:                                 Chris Pressey
4
5 PORTNAME=       lua50-app
6 PORTVERSION=    0.1
7 INTERNAL=       YES
8 CATEGORIES=     devel
9 DISTNAME=       luaapp-${PORTVERSION}
10 WRKSRC=         work/app
11
12 LIB_DEPENDS=    lua50.5:${PORTSDIR}/lang/lua50
13 BUILD_DEPENDS=  ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
14 RUN_DEPENDS=    ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51 \
15                 ${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix \
16                 ${LOCALBASE}/share/lua/5.0/filename.lua:${PORTSDIR}/devel/lua50-filename
17
18 MAINTAINER=     cpressey@catseye.mine.nu
19 COMMENT=        App framework for Lua 5.0.x
20
21 PLIST_FILES=    share/lua/5.0/app.lua
22
23 do-fetch:
24         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
25                 ${ECHO_MSG};                                                    \
26                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
27                 ${ECHO_MSG};                                                    \
28                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
29                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
30                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
31                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
32                 ${ECHO_MSG} "to create these distfiles.";                       \
33                 false;                                                          \
34         fi
35
36 do-build:
37         @${ECHO} "No building required."
38
39 do-install:
40         ${CP} ${WRKSRC}/app.lua ${LOCALBASE}/share/lua/5.0/app.lua
41
42 OSTYPE!=sysctl -n kern.ostype
43
44 .if ${OSTYPE} == "FreeBSD"
45 .include <bsd.port.mk>
46 .endif
47
48 .if ${OSTYPE} == "DragonFly"
49 .include <bsd.dfport.mk>
50 .endif