Merge from vendor branch LIBARCHIVE:
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-gettext / Makefile
1 # New ports collection makefile for:    lua50-gettext
2 # Date created:                         23 Feb 2005
3 # Whom:                                 Chris Pressey
4
5 PORTNAME=       lua50-gettext
6 PORTVERSION=    0.1
7 INTERNAL=       YES
8 CATEGORIES=     devel
9 DISTNAME=       luagettext-${PORTVERSION}
10 WRKSRC=         work/gettext
11
12 LIB_DEPENDS=    lua50.5:${PORTSDIR}/lang/lua50 \
13                 intl.6:${PORTSDIR}/devel/gettext
14 BUILD_DEPENDS=  ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
15 RUN_DEPENDS=    ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
16
17 MAINTAINER=     cpressey@catseye.mine.nu
18 COMMENT=        Gettext binding for Lua 5.0.x
19
20 PLIST_FILES=    lib/lua/5.0/lgettext.so \
21                 share/lua/5.0/gettext.lua
22
23 do-fetch:
24         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
25                 ${ECHO_MSG};                                                    \
26                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
27                 ${ECHO_MSG};                                                    \
28                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
29                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
30                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
31                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
32                 ${ECHO_MSG} "to create these distfiles.";                       \
33                 false;                                                          \
34         fi
35
36 do-install:
37         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/lgettext.so ${LOCALBASE}/lib/lua/5.0/
38         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/gettext.lua ${LOCALBASE}/share/lua/5.0/
39
40 OSTYPE!=sysctl -n kern.ostype
41
42 .if ${OSTYPE} == "FreeBSD"
43 .include <bsd.port.mk>
44 .endif
45
46 .if ${OSTYPE} == "DragonFly"
47 .include <bsd.dfport.mk>
48 .endif