tools/kq_recvserv: Add option to set receiving thread's CPU affinity.
[dragonfly.git] / UPDATING
1 # Updating Information for DragonFly users.
2 #
3 #
4 # This file should warn you of any pitfalls which you might need to work around
5 # when trying to update your DragonFly system.  The information below is
6 # in reverse-time order, with the latest information at the top.
7 #
8 # If you discover any problem, please contact the bugs@lists.dragonflybsd.org
9 # mailing list with the details.
10
11 +-----------------------------------------------------------------------+
12 +         UPGRADING DRAGONFLY FROM 4.6 TO LATER VERSIONS                +
13 +-----------------------------------------------------------------------+
14
15 NCV, NSP AND STG DRIVERS REMOVED
16 --------------------------------
17
18 They were all in our X86_64_GENERIC kernel configuration file, so any
19 custom configuration files derived from it need adjustment.
20
21 PORTAL FILE SYSTEM REMOVED
22 --------------------------
23
24 It has been broken for a long time now.
25
26 BINUTILS 2.27 REPLACES 2.24, PRIMARY
27 ------------------------------------
28
29 The oldest of the two versions of Binutils, version 2.24, was removed
30 and replaced with Binutils 2.27.  It becomes the primary version version
31 of binutils and version 2.25 becomes the alternate.
32
33 The accepted values of BINUTILSVER are now "binutils227" (default) and
34 "binutils225".  The building of Binutils 2.25 can be prevented by setting
35 NO_ALTBINUTILS=yes in make.conf.
36
37 COMPAT_43 KERNEL OPTION REMOVED
38 -------------------------------
39
40 It was commented out in our default configs for several years now, but
41 might still be present in custom configs created before Nov. 2011.
42
43 OPENSSL REMOVED
44 ---------------
45
46 OpenSSL has been removed from base and replaced with a private version of
47 LibreSSL.  The previously installed OpenSSL libraries, headers, and man
48 pages will remain on the system unless the "make upgrade" command is
49 specifically instructed to remove them.  To do this, define
50 REMOVE_OPENSSL_FILES for the upgrade command, e.g.
51 "make upgrade REMOVE_OPENSSL_FILES=yes"
52
53 28-Oct-2016: openssl has been replaced by ressl.  It is recommended that any
54 stale OpenSSL files be removed to avoid configuration scripts from using
55 the stale and potentially vulnerable version, but all binaries that are
56 dynamically linked to the OpenSSL libraries should be rebuilt first to
57 avoid breakage.
58
59 CS, EX AND VX DRIVERS REMOVED
60 -----------------------------
61
62 The cs(4), ex(4) and vx(4) drivers have been removed. They were very
63 old and its doubtful they ever worked properly in x86_64 but they were
64 in X86_64_GENERIC, so custom configurations derived from it have to be
65 adjusted.
66
67 +-----------------------------------------------------------------------+
68 +         UPGRADING DRAGONFLY FROM 4.4 TO LATER VERSIONS                +
69 +-----------------------------------------------------------------------+
70
71 AMD REMOVED
72 -----------
73
74 The am-utils automounter suite has been removed. It stopped working
75 at some point and was never fixed. autofs(5) and the associated
76 userland has been brought in from FreeBSD and replaces it.
77
78 AN DRIVER REMOVED
79 -----------------
80
81 The an(4) driver has been removed. It was in the X86_64_GENERIC kernel
82 config file, so any configurations derived from it have to be adjusted.
83
84 /DEV/DRI GROUP CHANGED
85 ----------------------
86
87 The default group assigned to /dev/dri entries has been changed
88 from 'wheel' to 'video' with the id of '44'. If you want to have
89 access to the dri devices please add yourself to the video group
90 with:
91
92 # pw groupmod video -m $USER
93
94 +-----------------------------------------------------------------------+
95 +         UPGRADING DRAGONFLY FROM 4.2 TO LATER VERSIONS                +
96 +-----------------------------------------------------------------------+
97
98 DSCHED REMOVED
99 --------------
100
101 dsched(4) has been removed and one of its kernel options, DSCHED_FQ, was
102 in our default kernel config file. So the DSCHED_FQ option has been turned
103 into a no-op for now and can be removed from custom configurations.
104
105 EST DRIVER REMOVED, COMPILE_ET AND LIBCOM_ERR TOO
106 -------------------------------------------------
107
108 The est(4) driver has been removed. All CPUs it supported (except one)
109 were 32 bits only. Those who are still using the Core 2 Duo T7500 should
110 report back if there are any issues with this CPU and our regular ACPI
111 P-state support.
112
113 Also, compile_et(1) and com_err(3) have been removed as well. They
114 should have been removed along with kerberos support, back in 2009.
115
116 SEVERAL LOCALES RENAMED
117 -----------------------
118
119 Several locales were using obsolete and misleading names, and thus have
120 been adjusted to current standards. Any users of the following locales
121 need to select alternates:
122
123 DFLY 4.2 locale            DFLY 4.4 alterative locale
124 ---------------            ------------------------------------
125 mn_MN.UTF-8                mn_Cyrl_MN.UTF-8
126 no_NO.UTF-8                nb_NO.UTF-8      or nn_NO.UTF-8
127 no_NO.ISO8859-1            nb_NO.ISO8869-1  or nn_NO.ISO8859-1
128 no_NO.ISO8859-15           nb_NO.ISO8859-15 or nn_NO.ISO8859-15
129 sr_YU.UTF-8                sr_Cyrl_RS.UTF-8 or sr_Latn_RS.UTF-8
130 sr_YU.ISO8859-5            sr_Cyrl_RS.ISO8859-5
131 sr_YU.ISO8859-2            sr_Latn_RS.ISO8859-2
132 zh_CN.GBK                  zh_Hans_CN.GBK
133 zh_CN.UTF-8                zh_Hans_CN.UTF-8
134 zh_CN.eucCN                zh_Hans_CN.eucCN
135 zh_CN.GB2312               zh_Hans_CH.GB2312
136 zh_CN.GB18030              zh_Hans_CH.GB18030
137 zh_HK.Big5HKSCS            zh_Hant_HK.Big5HKSCS
138 zh_HK.UTF_8                zh_Hant_HK.UTF-8
139 zh_TW.Big5                 zh_Hant_TW.Big5
140 zh_TW.UTF-8                zh_Hant_TW.UTF-8
141
142 +-----------------------------------------------------------------------+
143 +         UPGRADING DRAGONFLY FROM 4.0 TO LATER VERSIONS                +
144 +-----------------------------------------------------------------------+
145
146 BINUTILS 2.25 REPLACES 2.22, PRIMARY
147 ------------------------------------
148
149 The oldest of the two versions of Binutils, version 2.22, was removed
150 and replaced with Binutils 2.25.  It becomes the primary version version
151 of binutils and version 2.24 becomes the alternate.  There are 8 current
152 CVE written against 2.24, so for security reasons version 2.25 should
153 always be used.
154
155 The accepted values of BINUTILSVER are now "binutils225" (default) and
156 "binutils224".  The building of Binutils 2.24 can be prevented by setting
157 NO_ALTBINUTILS=yes in make.conf.
158
159 LOADER OPTIONS CHANGED
160 ----------------------
161
162 Right after the development branch started, the Fred art accompanying the
163 loader menu was improved.  The line between Fred and the menu was removed
164 by default (but can optionally be returned) and the placement shifted as
165 a result.  The drawing was improved, and the colored version was improved,
166 changing the eyes and wing color from white to red.  A new color version
167 of Fred was added, one with a blue scheme.
168
169 The loader menu defaults have changed since release 4.0:  The vertical
170 line was removed, the loader is displayed in color by default*, and the
171 blue scheme is used.
172
173 The loader.conf changes are:
174 loader_color:   option has been removed
175 loader_plain:   option has been added, it changed menu to monochrome
176 fred_is_red:    changes color scheme from blue to red
177 fred_is_blue:   option existed only on 4.1, it has been removed
178 fred_separated: Adds line between Fred and menu (as seen previously)
179
180 * If loader.conf defines "console" as "comconsole" or "console" is defined
181   in the environment as "comconsole" then color will not be displayed,
182   even if loader_plain value is "NO".
183
184 SENDMAIL REMOVED FROM BASE
185 --------------------------
186
187 The only Mail Transfer Agent provided now is DragonFly Mail Agent (dma).
188 If the system being upgraded is still configured to use the sendmail
189 binaries from base, the "make upgrade" command will fail.
190
191 The administrator must change /etc/mail/mailer.conf to switch the
192 mailwrapper to dma or a DPorts-based MTA prior to running the upgrade
193 command that permanently removes sendmail executables and could
194 potentially break a running mail server.
195
196 Refer: http://www.dragonflybsd.com/docs/docs/newhandbook/mta/ for
197 detailed instructions on how to configure the MTA selection.
198
199 _KPOSIX_VERSION and P1003_1B OPTIONS REMOVED
200 --------------------------------------------
201
202 The _KPOSIX_VERSION and P1003_1B kernel options have been changed to
203 no-ops. They can be removed from custom kernel configurations.
204
205 SOUND SYSTEM UPDATED FROM FreeBSD 11-CURRENT
206 --------------------------------------------
207
208 Many more sound devices may be detected.
209
210 If the default device choosen isn't to your liking, setting the sysctl
211 hw.snd.default_unit to a different number will change it.
212
213 SCTP SUPPORT DROPPED
214 --------------------
215
216 Support for the SCTP protocol has been removed.
217
218 OLD USB DRIVERS REMOVED
219 -----------------------
220
221 The old USB stack, along with the kernel config option "device oldusb"
222 and the make.conf variable "WANT_OLDUSB" have been removed. This means
223 that for custom kernel configuration files which were derived from a
224 GENERIC or X86_64_GENERIC file prior to making the usb4bsd stack default,
225 various (old USB stack specific) devices will now complain about being
226 unknown:
227
228   * oldusb      (obviously)
229   * natausb     (not yet ported to usb4bsd)
230   * rue         (not yet ported to usb4bsd)
231   * ugen        (no longer needed in usb4bsd)
232   * urio        (not yet ported to usb4bsd)
233   * uscanner    (no longer needed in usb4bsd)
234
235 They should be removed or commented out in such custom kernel configs.
236
237 GCC 5
238 -----
239
240 The GCC 4.4 compiler has been retired.  It has been replaced by a GCC 5.1.
241 The following make.conf variables no longer work: NO_GCC44, NO_OBJC, and
242 NO_CXX.  The latter was never documented and the latest versions of GCC are
243 partially written in C++ so a C++ compiler is no longer optional.  In
244 practical terms it has not been optional for many years as other base
245 components are also written in C++.  The resource savings by avoiding
246 building Objective-C compiler is so small, the complexity added by NO_OBJC
247 internally was deemed a bad tradeoff so that is the reason for its removal.
248 Also note that no "info" pages are installed with GCC 5.  After this entry
249 was originally written, all info pages were removed from DragonFly.
250
251 GCC 5.1 has been designated as the primary compiler.  As such, there is a
252 new make.conf variable, NO_ALTCOMPILER.  It will block the rebuilding of
253 the designated secondary compiler, GCC 4.7.  However, while DPorts
254 primarily uses GCC 5 to build ports now, it still uses GCC 4.7 as well, so
255 if building ports from source is desired, don't block building of the
256 secondary compiler.
257
258 +-----------------------------------------------------------------------+
259 +         UPGRADING DRAGONFLY FROM 3.8 TO LATER VERSIONS                +
260 +-----------------------------------------------------------------------+
261
262 SMP AND DEVICE_POLLING OPTIONS MADE UNKNOWN
263 -------------------------------------------
264
265 DEVICE_POLLING was replaced by IFPOLL_ENABLE and the former SMP code is
266 the default now (even on single-core systems), both for, like, 21 months.
267 We kept the options around as no-ops as a convenience, to allow people
268 using the same config for the then current release and the then current
269 master. That period is now over, so any configs still having those
270 options have to be adjusted.
271
272 SYSVIPC SYSCALLS MADE NON-OPTIONAL
273 ----------------------------------
274
275 The code related to the SYSVMSG, SYSVSEM and SYSVSHM kernel options is
276 now compiled in by default. The options are no-ops for now.
277
278 DEFAULT DRIVER CHANGED FOR LSI "THUNDERBOLT" SERIES RAID CONTROLLERS
279 --------------------------------------------------------------------
280
281 The default driver for those controllers is now mrsas(4) due to reports
282 of file system corruption using the mfi(4) driver. The whole issue (and
283 how to deal with potential problems when switching) was explained here:
284
285 http://lists.dragonflybsd.org/pipermail/users/2014-July/128703.html
286
287 A tunable is provided for letting those controllers still attach via
288 the mfi(4) driver, hw.mrsas.mfi_enable (see mrsas(4) manual page).
289
290 OLDER NETWORK DRIVERS MOVED TO I386 ONLY
291 ----------------------------------------
292
293 The following drivers have been made i386 only: ed(4), sr(4), ng_sync_ar
294 and ng_sync_sr. ed(4) used to be in X86_64_GENERIC, so it has to be
295 removed in kernel configs derived from X86_64_GENERIC.
296
297 +-----------------------------------------------------------------------+
298 +         UPGRADING DRAGONFLY FROM 3.6 TO LATER VERSIONS                +
299 +-----------------------------------------------------------------------+
300
301 UPDATE FROM MOST RECENT 3.6
302 ---------------------------
303
304 Versions of 3.6 built before June 25th have a bug where installworld might 
305 crash during installation of the new initrd.  Upgrade to the latest version
306 of 3.6 before updating to 3.8 or later.
307
308 ATM, IPX, NCP AND NWFS SUPPORT DROPPED
309 --------------------------------------
310
311 Support for the IPX and NCP network protocols and for mouting NetWare
312 file systems has been dropped. Dito for ATM protocol support.
313
314 INITRD IMAGES NOW INSTALLED BY DEFAULT
315 --------------------------------------
316
317 An initial ramdisk image is now installed in /boot/kernel/initrd.img.gz
318
319 Older images installed under the file name of initrd.img will be removed
320 automatically by the make upgrade process.
321
322 USB4BSD IS NOW THE DEFAULT USB STACK
323 ------------------------------------
324
325 To get back to the old stack, put "WANT_OLDUSB=yes" in /etc/make.conf and
326 replace "device usb" with "device oldusb" in the kernel configuration.
327
328 MORE ISA SUPPORT DROPPED
329 ------------------------
330
331 ISA support has been dropped from the following drivers: adv(4), an(4),
332 ar(4), cs(4), digi(4), ed(4), ep(4), ex(4), fe(4), lnc(4), sbni(4),
333 si(4), sn(4), and stg(4).
334
335 +-----------------------------------------------------------------------+
336 +         UPGRADING DRAGONFLY FROM 3.4 TO LATER VERSIONS                +
337 +-----------------------------------------------------------------------+
338
339 ABI CHANGE
340 ----------
341
342 Installed third-party software (dports) will have to be rebuilt after upgrade,
343 or reinstalled from binary packages.
344
345 UPDATING FROM 3.4 TO 3.6
346 ------------------------
347
348 This only applies for this specific upgrade due to locale changes; it is 
349 not needed for upgrades after 3.6.  Please update in this order:
350
351 make buildworld
352 make buildkernel
353 make installworld
354 make installkernel
355 *reboot*
356 make upgrade
357
358 See this mailing list post for details:
359 http://lists.dragonflybsd.org/pipermail/users/2013-September/090163.html
360
361 CYRIX OPTIONS REMOVED
362 ---------------------
363
364 The following Cyrix related options have been removed: CPU_BTB_EN,
365 CPU_CYRIX_NO_LOCK, CPU_DIRECT_MAPPED_CACHE, CPU_DISABLE_5X86_LSSER,
366 CPU_FASTER_5X86_FPU, CPU_IORT, CPU_LOOP_EN, CPU_RSTK_EN, CPU_SUSP_HLT,
367 CYRIX_CACHE_WORKS, and CYRIX_CACHE_REALLY_WORKS
368
369 ISA SUPPORT REMOVED FROM RP(4)
370 ------------------------------
371
372 ISA support has been removed from the rp(4) driver. It is now PCI only.
373
374 +-----------------------------------------------------------------------+
375 +         UPGRADING DRAGONFLY FROM 3.2 TO LATER VERSIONS                +
376 +-----------------------------------------------------------------------+
377
378 COMPAT_SUNOS OPTION REMOVED
379 ---------------------------
380
381 The COMPAT_SUNOS option has been removed. It was meant to provide binary
382 compatibility with SunOS 4.x for the sparc32 port of 4.4BSD.
383
384 ISA SOUND CARD SUPPORT REMOVED
385 ------------------------------
386
387 The following modules have been removed (all for ISA sound cards):
388 snd_ad1816.ko, snd_ess.ko, snd_mss.ko, snd_sb8.ko, snd_sb16.ko, snd_sbc.ko
389
390 GCC 4.7
391 -------
392
393 DragonFly has switched base compilers.  GCC 4.7 is now the default
394 compiler and GCC 4.4 is the alternative compiler.  The "NO_GCC47" make
395 variable ceases to work now.
396
397 Users who wish to build only GCC 4.7 have to use NO_GCC44 in the
398 /etc/make.conf to prohibit GCC 4.4 from building.  However, using it is
399 highly discouraged.  There are a few packages in pkgsrc that do not build
400 with GCC 4.7 and the new "DPorts" system uses GCC 4.4 by default.  At
401 this time, it is recommended to keep both compilers on the base system.
402
403 SMP OPTION REMOVED
404 ------------------
405
406 The SMP kernel option has been made a no-op. All kernels now feature SMP
407 support. If you have 'options SMP' in your kernel config, you can as well
408 remove it.
409
410 DEVICE_POLLING OPTION REPLACED BY IFPOLL_ENABLE OPTION, KTR_POLLING REMOVED
411 ---------------------------------------------------------------------------
412
413 The DEVICE_POLLING kernel option has been made a no-op and it has been
414 replaced by IFPOLL_ENABLE.  If you have 'options DEVICE_POLLING' in your
415 kernel config, you need to change it to IFPOLL_ENABLE.
416
417 Also, the KTR_POLLING kernel option has been removed, so it must be
418 removed from kernel configs that have it.
419
420 BUSLOGIC, CYCLADES AND STALLION ISA SUPPORT REMOVED
421 ---------------------------------------------------
422
423 The bt(4) driver for Buslogic SCSI adapters has been made PCI only. ISA
424 cards will no longer be detected.
425
426 The same has been done for Stallion multiport serial controllers. stli(4)
427 has been completely removed (along with the stlload(8) and stlstty(8)
428 utilities) and stl(4) was changed to support only PCI cards. Similarly,
429 ISA support was removed from cy(4) too. All these drivers are i386 only.
430
431 COMPAT_OLDISA OPTION GONE
432 -------------------------
433
434 The i386 specific COMPAT_OLDISA kernel option has been removed, since
435 nothing needs it anymore.
436
437 +-----------------------------------------------------------------------+
438 +         UPGRADING DRAGONFLY FROM 3.0 TO LATER VERSIONS                +
439 +-----------------------------------------------------------------------+
440
441 APIC_IO OPTION REMOVED
442 ----------------------
443
444 The APIC_IO kernel option is no longer accepted after having been without
445 effect for a while. The hw.ioapic_enable tunable now serves its purpose.
446 If you have 'options APIC_IO' in your kernel config, you'll have to
447 remove it.
448
449 WATCHDOG_ENABLE & HW_WDOG OPTIONS REMOVED
450 -----------------------------------------
451
452 The wdog framework is now compiled into our kernels by default, so the
453 options are no longer needed.
454
455 DOSCMD(1) REMOVED
456 -----------------
457
458 doscmd(1) has been removed. It was i386 only. The doscmd(1) specific
459 NO_X make.conf option was removed too.
460
461 GCC 4.7
462 -------
463
464 GCC 4.7 has been brought in and replaces GCC 4.1 as DragonFly's non-
465 default compiler in base (default is still GCC 4.4).
466
467 Users who wish to build only GCC 4.4 have to replace NO_GCC41 with
468 NO_GCC47 in /etc/make.conf.
469
470 USB4BSD
471 -------
472
473 A new USB stack (from FreeBSD) has been brought in. The following
474 modules have been ported so far: usb, uhci, ohci, ehci, xhci, umass,
475 usfs, uether, if_axe, if_udav, ukbd, ums, uep, uhid, usb_quirk,
476 and uaudio.
477
478 It is not yet the default. To activate it, WANT_USB4BSD=yes has to
479 be put in make.conf and device "usb4bsd" (quotes needed) has to
480 replace device usb in the kernel config. After that, a full
481 build/install/upgrade cycle is needed.
482
483 Note that this is experimental and incomplete, but we are interested
484 in hearing about issues with it, of course.
485
486 ISA SUPPORT REMOVED FROM AIC-6260/6360 DRIVER
487 ---------------------------------------------
488
489 ISA adapter support was dropped from the aic(4) driver.
490
491 +-----------------------------------------------------------------------+
492 +         UPGRADING DRAGONFLY FROM 2.10 TO LATER VERSIONS               +
493 +-----------------------------------------------------------------------+
494
495 SEVERAL ISA DRIVERS REMOVED
496 ---------------------------
497
498 The following ISA only drivers have been removed along with a couple of
499 associated userland tools:
500
501 aha(4)
502 asc(4) & sasc(1)
503 ctx
504 dgb(4)
505 el(4)
506 gpib
507 gsc(4) & sgsc(1)
508 ie(4)
509 labpc(4)
510 le(4)
511 mse(4)
512 rc(4)
513 rdp(4)
514 spigot
515 tw(4) & xten(1) & xtend(8)
516 wl(4) & wlconfig(8)
517 wt(4)
518
519 Note that two of these drivers (aha(4) and ie(4)) are in our GENERIC
520 config and one (aha(4)) is in our X86_64_GENERIC kernel configuration
521 file.
522
523 If buildkernel complains about any of these drivers, just remove them
524 from your kernel configuration.
525
526 BINUTILS 2.20
527 -------------
528 Binutils 2.20 has been removed in favor of Binutils 2.22.  The accepted
529 values of BINUTILSVERS are now binutils221 and binutils222 (default).
530
531 BUILDWORLD/-KERNEL PARALLELIZATION WORK
532 ---------------------------------------
533 Due to changes in the way we build with more than one make job, you
534 will have to update install(1) and mkdir(1) prior to buildworld if you
535 want to build with 'make -j':
536
537 cd /usr/src/usr.bin/xinstall; make; make install; make clean
538 cd /usr/src/bin/mkdir; make; make install; make clean
539
540 DMA(8) UPGRADE
541 --------------
542 dma(8) has been upgraded to v0.7 which no longer supports the
543 /etc/dma/virtusertable. Some of its functionality has been replaced
544 with the MASQUERADE keyword and the EMAIL environment variable (see
545 the dma(8) manual page).
546
547 +-----------------------------------------------------------------------+
548 +         UPGRADING DRAGONFLY FROM 2.8 TO LATER VERSIONS                +
549 +-----------------------------------------------------------------------+
550
551 GCC 4.4 & BINUTILS 2.21
552 -----------------------
553
554 GCC 4.4 has been made DragonFly's default compiler and Binutils 2.21 has
555 been made DragonFly's default Binutils.
556
557 That means that any settings that set CCVER to 'gcc44' are not needed
558 anymore. Instead, CCVER can be set to 'gcc41' to go back to using
559 GCC 4.1.
560
561 It also means that 'binutils221' as a value for BINUTILSVER has no
562 effect anymore. 2.17 has been removed and 'binutils220' is available
563 as an option.
564
565 The NO_GCC44 option has been removed and will not affect the build
566 anymore. There is now a NO_GCC41 option that will prevent GCC 4.1 from
567 building in a similar fashion.
568
569 Note that you must do a full buildworld/buildkernel for upgrading.
570
571 pkg_radd settings
572 -----------------
573
574 The config file for pkg_radd has moved from /etc/settings.conf to 
575 /etc/pkg_radd.conf.  Save the contents of settings.conf before upgrading
576 if this is needed.  This warning only applies if /etc/settings.conf 
577 exists.  pkg_radd will continue to work with defaults.
578
579 +-----------------------------------------------------------------------+
580 +         20100927                                                      +
581 +         UPGRADING DRAGONFLY FROM 2.6 to 2.8 or HEAD                   +
582 +-----------------------------------------------------------------------+
583
584 OpenSSL
585 --------
586
587 OpenSSL has been upgraded, and SHLIB_MAJOR was bumped for libssh and libcrypto.
588 This shouldn't break any 3rd-party software, but you'll need to recompile your
589 3rd-party software if you want it to link against the new version of OpenSSL.
590
591 Loader
592 -------
593
594 A new loader (dloader) has been added which better handles booting from
595 multiple kernel/module versions.
596
597 To upgrade (Only for this upgrade, for post 2.8 upgrades see GENERAL below)
598
599         cd /usr/src
600         make buildworld
601         make installworld
602         make upgrade
603         make buildkernel KERNCONF=<KERNELNAME>
604         make installkernel KERNCONF=<KERNELNAME>
605
606 Note that you must installworld and run the 'upgrade' target before
607 installing the new kernel.
608
609 BIND
610 -----
611
612 BIND has been removed from the base system.  The ldns and drill tools have 
613 been added for basic functionality.  Use 'drill' where you would normally 
614 use nslookup or dig, or install BIND from pkgsrc.  It's available as 
615 net/bind95, net/bind96, or net/bind97 as of this writing.
616
617 This only affects older systems upgrading to 2.8.  New 2.8+ installs 
618 include BIND as a pkgsrc package.
619
620 +-----------------------------------------------------------------------+
621 +         UPGRADING DRAGONFLY ON AN EXISTING DRAGONFLY SYSTEM           +
622 +                               GENERAL                                 +
623 +-----------------------------------------------------------------------+
624
625 Instructions on how to obtain and maintain DragonFly source code using git
626 are in the development(7) manual page.
627
628 To upgrade a DragonFly system from sources you run the following sequence:
629
630         cd /usr/src
631         make buildworld
632         make buildkernel KERNCONF=<KERNELNAME>
633         make installkernel KERNCONF=<KERNELNAME>
634         make installworld
635
636 You will also want to run the 'upgrade' target to upgrade your /etc and the
637 rest of your system.  The upgrade target is aware of stale files created by
638 older DragonFly installations and should delete them automatically.
639
640         make upgrade
641
642 See the build(7) manual page for further information.
643
644 Once you've done a full build of the world and kernel you can do incremental
645 upgrades of either by using the 'quickworld' and 'quickkernel' targets
646 instead of 'buildworld' and 'buildkernel'.  If you have any problems with
647 the quick targets, try updating your repo first, and then a full buildworld
648 and buildkernel as shown above, before asking for help.
649
650 +-----------------------------------------------------------------------+
651 +         UPGRADING FROM DRAGONFLY <= 2.0 TO DRAGONFLY >= 2.1           +
652 +-----------------------------------------------------------------------+
653
654 In 2.1 kernel and modules has moved to boot directory.  For most cases
655 this is handled automatically by 'make upgrade'.  A few cases needs manual
656 intervention:
657
658  * When installing a kernel without first doing a make buildworld,
659    installworld and upgrade to the same DESTDIR as kernel:
660    make DESTDIR/boot directory and move kernel and modules into this boot
661    directory; also move kernel.old and modules.old.
662    Typical example is vkernel(7), use (no modules used):
663
664         cd /var/vkernel
665         mkdir boot
666         chflags noschg kernel
667         mv kernel kernel.old boot
668         chflags schg boot/kernel
669         
670  * When using a boot-only partition, /boot/loader.rc needs to be edited:
671    delete occurrences of '/boot/'.
672    These occurences can normally be deleted in any case, see loader(8).
673
674 +-----------------------------------------------------------------------+
675 +         UPGRADING FROM DRAGONFLY <= 1.8 TO DRAGONFLY >= 1.9           +
676 +-----------------------------------------------------------------------+
677
678 In 1.9 major changes to the disk management infrastructure have taken
679 place.  make upgrade may not catch all of your disk devices in /dev,
680 so after upgrading be sure to cd /dev; ./MAKEDEV <blah> where <blah>
681 are all of your disk devices.  HOWEVER, from late 2.3 on we run devfs
682 and MAKEDEV no longer exists.
683
684 The biggest changes in 1.9 are:
685
686 (1) That whole-slice devices such as da0s1 no longer share the same device
687     id as partition c devices such as da0s1c.
688
689 (2) The whole-disk device (e.g. da0) is full raw access to the disk,
690     with no snooping or reserved sectors.  Consequently you cannot run
691     disklabel on this device.  Instead you must run disklabel on a
692     whole-slice device.
693
694 (3) The 'compatibility' partitions now use slice 0 in the device name,
695     so instead of da0a you must specify da0s0a.  Also, as per (1) above,
696     accessing the disklabel for the compatibility partitions must be
697     done via slice 0 (da0s0).
698
699 (4) Many device drivers that used to fake up labels, such as CD, ACD, VN,
700     and CCD now run through the disk management layer and are assigned
701     real disk management devices.   VN and CCD in particular do not usually
702     use a MBR and disklabels must be accessed through the compatibility
703     slice 0.  Your /etc/ccd.conf file still specifies 'ccd0', though, you
704     don't name it 'ccd0s0' in the config file.
705
706 Generally speaking, you have to get used to running fdisk and disklabel on
707 the correctly specified device names.  A lot of the wiggle, such as running
708 disklabel on a partition, has been removed.
709
710 +-----------------------------------------------------------------------+
711 +         UPGRADING FROM OLDER VERSIONS OF DRAGONFLY OR FREEBSD         +
712 +-----------------------------------------------------------------------+
713
714 > Kerberos IV
715 -------------
716
717 Kerberos IV (eBones) was removed from the tree, please consider moving to
718 Kerberos 5 (Heimdal).
719
720 > Package Management System
721 ---------------------------
722
723 Starting with the 1.4 release, DragonFly uses NetBSD's pkgsrc package
724 management system.  The necessary tools to build and maintain packages
725 are provided in /usr/pkg/bin and /usr/pkg/sbin.  Make sure that these
726 directories are in your PATH variable.
727
728 In order to obtain a reasonably current snapshot of the pkgsrc tree, use
729 the tarball from NetBSD:
730
731         fetch -o /tmp/pkgsrc.tar.gz ftp://ftp.NetBSD.org/pub/NetBSD/packages/pkgsrc.tar.gz
732         cd /usr; tar -xzf /tmp/pkgsrc.tar.gz; chown -R root:wheel pkgsrc
733
734 This tree can then be kept up to date with cvs update:
735
736         cd /usr/pkgsrc; cvs up
737
738 NOTE! If you upgraded from a pre-1.4 system to 1.4 or later, you need to
739 build and install the pkgsrc bootstrap manually:
740
741         cd /usr/pkgsrc/bootstrap
742         ./bootstrap --pkgdbdir /var/db/pkg --prefix /usr/pkg
743
744 +-----------------------------------------------------------------------+
745 +         UPGRADING DRAGONFLY ON AN EXISTING DRAGONFLY SYSTEM           +
746 +         UPDATING FROM PRE-1.2 SYSTEMS OR FreeBSD 4.x TO               +
747 +         DRAGONFLY 1.3+ (EITHER PREVIEW or HEAD)                       +
748 +-----------------------------------------------------------------------+
749
750 The compatibility shims for the build environment have been removed, you
751 have to update to DragonFly 1.2 release branch first.
752
753 The default PAM configuration has moved from /etc/pam.conf to /etc/pam.d/.
754 The existing configuration can be converted using /etc/pam.d/convert.sh.
755 Entries in /etc/pam.d/ override entries in /etc/pam.conf. In addition
756 the pam_skey.so module was retired, you have to remove it manually from
757 your configuration, when you convert it.
758
759 > Required user and group IDs when upgrading from either FreeBSD or DragonFly
760 ---------------------
761
762 The following users may be missing from your password file.  Use vipw and
763 add any that are missing:
764
765 smmsp:*:25:25::0:0:Sendmail Submission User:/var/spool/clientmqueue:/sbin/nologin
766 _pflogd:*:64:64::0:0:pflogd privsep user:/var/empty:/sbin/nologin
767
768 The following groups may be missing from your group file.  Use vi /etc/group
769 and add any that are missing:
770
771 smmsp:*:25:
772 authpf:*:63:
773 _pflogd:*:64:
774
775
776 > Upgrading to DragonFly from FreeBSD
777 ---------------------
778
779 You can build the DragonFly world and DragonFly kernels on a FreeBSD-4.x or
780 FreeBSD-5.x machine and then install DragonFly over FreeBSD, replacing
781 FreeBSD.  Note that the DragonFly buildworld target does not try to reuse
782 make depend information, it starts from scratch, so no pre-cleaning of the
783 object hierarchy is necessary.
784
785         # get the CVS repository (it is placed in /home/dcvs, 500MB).
786         # Please use the -h option and a mirror site to pull the 
787         # initial repository, but feel free to use the main repository
788         # machine to pull updates.
789         cvsup /usr/share/examples/cvsup/DragonFly-cvs-supfile
790         # install the source from the CVS hierarchy (remove preexisting
791         # FreeBSD src first) (500MB)
792         cd /usr
793         rm -rf src
794         cvs -R -d /home/dcvs checkout -P src
795
796         # build it (500MB used in /usr/obj)
797         #
798         cd /usr/src
799         make buildworld
800         make buildkernel KERNCONF=<KERNELNAME>
801
802 Once you have built DragonFly you have to install it over FreeBSD.  Since
803 DragonFly does not track changes made by FreeBSD to its include file 
804 hierarchy and include file pollution can cause all sorts of unexpected
805 compilation issues to come up, it is best to wipe your include hierarchy
806 prior to installing DragonFly.  Note that you should not wipe any installed
807 FreeBSD header files or binaries until after you have successfully completed
808 the build steps above.
809
810         rm -rf /usr/include
811         mkdir /usr/include
812         make installkernel KERNCONF=<KERNELNAME>
813         make installworld
814
815 Then you need to upgrade your system.  DragonFly's 'make upgrade' target 
816 will unconditionally upgrade the /etc files that sysops do not usually
817 mess around with, such as the files in /etc/rc.d.  It will also remove any
818 obsolete files such as utilities and manpages that have been removed from
819 the system since the version you're coming from.  If you are unsure we 
820 recommend that you make a backup of at least your /etc before applying
821 this step.  Note that DragonFly's RC system is basically RCNG from
822 FreeBSD-5, but there are some differences in the contents of the RC files.
823
824         make upgrade
825
826 NOTE! Never do a 'make upgrade' before 'make installworld' has been run.
827 Doing so might leave your system in an unusable state.
828
829 Finally we recommend that you do an 'ls -lta BLAH' for /bin, /sbin, /usr/bin,
830 /usr/bin, and /usr/lib, and remove any stale files that you find.  Please
831 report these files to the DragonFly developers so that they can be added to
832 the 'upgrade' target.
833