Update libedit from NetBSD.
[dragonfly.git] / secure / usr.sbin / sshd / auth.c.patch
1 # $DragonFly: src/secure/usr.sbin/sshd/Attic/auth.c.patch,v 1.2 2004/08/30 21:59:58 geekgod Exp $
2 --- /home/sullrich/openssh-3.9p1/auth.c 2004-08-19 17:28:41.000000000 +0000
3 +++ /usr/src/crypto/openssh-3.9p1/auth.c        2004-08-12 12:40:25.000000000 +0000
4 @@ -472,7 +472,7 @@
5         if (!allowed_user(pw))
6                 return (NULL);
7  #ifdef HAVE_LOGIN_CAP
8 -       if ((lc = login_getpwclass(pw)) == NULL) {
9 +       if ((lc = login_getclass(pw->pw_class)) == NULL) {
10                 debug("unable to get login class: %s", user);
11                 return (NULL);
12         }