Merge from vendor branch LESS:
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / libaura / Makefile
1 # New ports collection makefile for:    libaura
2 # Date created:                 July 21, 2004
3 # Whom:                         Chris Pressey <cpressey@catseye.mine.nu>
4
5 PORTNAME=       libaura
6 PORTVERSION=    3.1
7 INTERNAL=       YES
8 CATEGORIES=     sysutils
9 DISTNAME=       ${PORTNAME}-${PORTVERSION}
10 WRKSRC=         work/${PORTNAME}
11
12 MAINTAINER=     cpressey@catseye.mine.nu
13 COMMENT=        Library of Assorted Useful Reusable Abstractions
14
15 PLIST_FILES=    lib/libaura.a                   \
16                 lib/libaura.so                  \
17                 lib/libaura.so.3                \
18                 include/aura/buffer.h           \
19                 include/aura/dict.h             \
20                 include/aura/fspred.h           \
21                 include/aura/popen.h            \
22                 include/aura/mem.h
23
24 do-fetch:
25         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
26                 ${ECHO_MSG};                                                    \
27                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
28                 ${ECHO_MSG};                                                    \
29                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
30                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
31                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
32                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
33                 ${ECHO_MSG} "to create these distfiles.";                       \
34                 false;                                                          \
35         fi
36
37 do-install:
38         ${MKDIR} -p ${LOCALBASE}/include/aura
39         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/libaura.a ${LOCALBASE}/lib/
40         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/libaura.so.3 ${LOCALBASE}/lib/
41         ${LN} -sf ${LOCALBASE}/lib/libaura.so.3 ${LOCALBASE}/lib/libaura.so
42         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/buffer.h ${LOCALBASE}/include/aura/
43         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/dict.h ${LOCALBASE}/include/aura/
44         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/popen.h ${LOCALBASE}/include/aura/
45         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/fspred.h ${LOCALBASE}/include/aura/
46         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/mem.h ${LOCALBASE}/include/aura/
47
48 OSTYPE!=sysctl -n kern.ostype
49
50 .if ${OSTYPE} == "FreeBSD"
51 .include <bsd.port.mk>
52 .endif
53
54 .if ${OSTYPE} == "DragonFly"
55 .include <bsd.dfport.mk>
56 .endif
57