Merge from vendor branch GCC:
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-pty / Makefile
1 # New ports collection makefile for:    lua50-pty
2 # Date created:                         3 Apr 2005
3 # Whom:                                 Chris Pressey
4
5 PORTNAME=       lua50-pty
6 PORTVERSION=    0.1
7 INTERNAL=       YES
8 CATEGORIES=     devel
9 DISTNAME=       luapty-${PORTVERSION}
10 WRKSRC=         work/pty
11
12 LIB_DEPENDS=    lua50.5:${PORTSDIR}/lang/lua50
13 BUILD_DEPENDS=  ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
14 RUN_DEPENDS=    ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
15
16 MAINTAINER=     cpressey@catseye.mine.nu
17 COMMENT=        Pty (pseudo-terminal) bindings for Lua 5.0.x
18
19 PLIST_FILES=    lib/lua/5.0/lpty.so \
20                 share/lua/5.0/pty.lua
21
22 do-fetch:
23         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
24                 ${ECHO_MSG};                                                    \
25                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
26                 ${ECHO_MSG};                                                    \
27                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
28                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
29                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
30                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
31                 ${ECHO_MSG} "to create these distfiles.";                       \
32                 false;                                                          \
33         fi
34
35 do-install:
36         ${INSTALL_DATA} ${WRKSRC}/lpty.so ${PREFIX}/lib/lua/5.0
37         ${INSTALL_DATA} ${WRKSRC}/pty.lua ${PREFIX}/share/lua/5.0
38
39 OSTYPE!=sysctl -n kern.ostype
40
41 .if ${OSTYPE} == "FreeBSD"
42 .include <bsd.port.mk>
43 .endif
44
45 .if ${OSTYPE} == "DragonFly"
46 .include <bsd.dfport.mk>
47 .endif