Remove some !FreeBSD compat code, which produces warnings on DragonFly.