pkgsrc - initial commit
[pkgsrc.git] / archivers / libarchive / files / contrib / libarchive.spec
1 # $Revision: 1.1.1.1 $, $Date: 2007/11/30 21:25:32 $
2 Summary:        Library to create and read several different archive formats
3 Summary(pl):    Biblioteka do tworzenia i odczytu ró¿nych formatów archiwów
4 Name:           libarchive
5 Version:        2.0a3
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 Source0: http://people.freebsd.org/~kientzle/libarchive/src/%{name}-%{version}.tar.gz
10 Patch:          %{name}-0123457890.patch
11 URL:            http://people.freebsd.org/~kientzle/libarchive/
12 Requires:       glibc
13 Requires:       zlib
14 Requires:       bzip2
15 BuildRequires:  gcc
16 BuildRequires:  gcc-c++
17 BuildRequires:  gawk
18 BuildRequires:  zlib-devel
19 BuildRequires:  bzip2
20 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
21
22 %description
23 Libarchive is a programming library that can create and read several
24 different streaming archive formats, including most popular TAR
25 variants and several CPIO formats. It can also write SHAR archives.
26
27 %description -l pl
28 Libarchive jest bibliotek± s³u¿ac± to tworzenia i odczytu wielu
29 ró¿nych strumieniowych formatów archiwów, w³±czaj±c w to popularne
30 odmiany TAR oraz wiele formatów CPIO. Biblioteka ta potrafi tak¿e
31 zapisywaæ archiwa SHAR.
32
33 %package devel
34 Summary:        Header files for libarchive library
35 Summary(pl):    Pliki nag³ówkowe biblioteki libarchive
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for libarchive library.
41
42 %description devel -l pl
43 Pliki nag³ówkowe biblioteki libarchive.
44
45 %package static
46 Summary:        Static libarchive library
47 Summary(pl):    Statyczna biblioteka libarchive
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libarchive library.
53
54 %description static -l pl
55 Statyczna biblioteka libarchive.
56
57 %package -n bsdtar
58 Summary:        bsdtar - tar(1) implementation based on libarchive
59 Summary(pl):    bsdtar - implementacja programu tar(1) oparta na libarchive
60 Group:          Applications/Archiving
61 Requires:       %{name} = %{version}-%{release}
62
63 %description -n bsdtar
64 bsdtar - tar(1) implementation based on libarchive.
65
66 %description -n bsdtar -l pl
67 bsdtar - implementacja programu tar(1), oparta na libarchive.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 mkdir -p %{buildroot}
75 ./configure \
76 --prefix=%{_prefix} \
77 --libexecdir=%{_libexecdir} \
78 --mandir=%{_mandir} \
79 --infodir=%{_infodir} \
80 --enable-shared=yes \
81 --enable-static=yes \
82 | tee %{buildroot}/config.log
83 make | tee %{buildroot}/make.log
84
85 %install
86 [ "%buildroot" != "/" ] && [ -d %buildroot ] && rm -rf %buildroot;
87 make DESTDIR=%buildroot install
88 # original install builds, but does install bsdtar
89 cp .libs/%{name}.a %{buildroot}%{_libdir}
90 cp bsdtar %{buildroot}%{_bindir}
91 cp tar/bsdtar.1 %{buildroot}%{_mandir}/man1
92
93 %clean
94 rm -fr %buildroot
95
96 %files
97 %defattr(644,root,root,755)
98 %{_libdir}/libarchive.a
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_libdir}/libarchive.la
103 %{_includedir}/*.h
104 %doc %{_mandir}/man3/*
105 %doc %{_mandir}/man5/*
106
107 %files -n bsdtar
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/bsdtar
110 %doc %{_mandir}/man1/bsdtar.1*
111
112 %define date    %(echo `LC_ALL="C" date +"%a %b %d %Y"`)
113 %changelog
114 * %{date} PLD Team <feedback@pld-linux.org>
115 All persons listed below can be reached at <cvs_login>@pld-linux.org
116
117 $Log: libarchive.spec,v $
118 Revision 1.1.1.1  2007/11/30 21:25:32  joerg
119 Import libarchive-2.4.0
120
121 Release 1  2006/12/12 rm1023@dcx.com
122 - added libarchive-0123457890.patch for "0123457890" error
123 - replaced libarchive-1.3.1.tar.gz with libarchive-2.0a3.tar.gz
124 - removed obsolete -CVE-2006-5680.patch and -man_progname.patch
125
126 Revision 1.6  2006/11/15 10:41:28  qboosh
127 - BR: acl-devel,attr-devel
128 - devel deps
129
130 Revision 1.5  2006/11/08 22:22:25  twittner
131 - up to 1.3.1
132 - added BR: e2fsprogs-devel
133 - added -CVE-2006-5680.patch agains entering in infinite
134 loop in corrupt archives
135 - added bsdtar package (bsdtar is included now in libarchive
136 sources)
137 - rel. 0.1 for testing
138
139 Revision 1.4  2005/12/15 18:26:36  twittner
140 - up to 1.2.37
141 - removed -shared.patch (no longer needed)
142
143 Revision 1.3  2005/10/05 17:00:12  arekm
144 - up to 1.02.034
145
146 Revision 1.2  2005/07/27 20:17:21  qboosh
147 - typo
148
149 Revision 1.1  2005/07/27 08:36:03  adamg
150 - new