Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-filesystem / Makefile
1 # New ports collection makefile for:    lua50-filesystem
2 # Date created:                         10 Feb 2005
3 # Whom:                                 Chris Pressey
4
5 PORTNAME=       lua50-filesystem
6 PORTVERSION=    1.0
7 CATEGORIES=     devel
8 DISTNAME=       luafilesystem-${PORTVERSION}
9 MASTER_SITES=   http://luaforge.net/frs/download.php/430/
10
11 LIB_DEPENDS=    lua50.5:${PORTSDIR}/lang/lua50
12 BUILD_DEPENDS=  ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
13 RUN_DEPENDS=    ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
14
15 MAINTAINER=     cpressey@catseye.mine.nu
16 COMMENT=        Portable File System routines for Lua 5.0.x
17
18 PLIST_FILES=    lib/lua/5.0/liblfs.1.0.so       \
19                 lib/lua/5.0/lfs.so
20
21 ALL_TARGET=     lib
22
23 OSTYPE!=sysctl -n kern.ostype
24
25 .if ${OSTYPE} == "FreeBSD"
26 .include <bsd.port.mk>
27 .endif
28
29 .if ${OSTYPE} == "DragonFly"
30 .include <bsd.dfport.mk>
31 .endif
32