Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / sysutils / libinstaller / Makefile
1 # New ports collection makefile for:    libinstaller
2 # Date created:                 Aug 8, 2004
3 # Whom:                         Chris Pressey <cpressey@catseye.mine.nu>
4
5 PORTNAME=       libinstaller
6 PORTVERSION=    5.1
7 INTERNAL=       YES
8 CATEGORIES=     sysutils
9 DISTNAME=       ${PORTNAME}-${PORTVERSION}
10 WRKSRC=         work/${PORTNAME}
11
12 LIB_DEPENDS=    aura.3:${PORTSDIR}/devel/libaura \
13                 dfui.4:${PORTSDIR}/sysutils/libdfui
14
15 MAINTAINER=     cpressey@catseye.mine.nu
16 COMMENT=        BSD Installer library
17
18 PLIST_FILES=    lib/libinstaller.a              \
19                 lib/libinstaller.so             \
20                 lib/libinstaller.so.5           \
21                 include/installer/commands.h    \
22                 include/installer/confed.h      \
23                 include/installer/diskutil.h    \
24                 include/installer/functions.h   \
25                 include/installer/package.h     \
26                 include/installer/uiutil.h
27
28 do-fetch:
29         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
30                 ${ECHO_MSG};                                                    \
31                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
32                 ${ECHO_MSG};                                                    \
33                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
34                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
35                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
36                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
37                 ${ECHO_MSG} "to create these distfiles.";                       \
38                 false;                                                          \
39         fi
40
41 do-install:
42         ${MKDIR} -p ${LOCALBASE}/include/installer
43         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/libinstaller.a ${LOCALBASE}/lib/
44         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/libinstaller.so.5 ${LOCALBASE}/lib/
45         ${LN} -sf ${LOCALBASE}/lib/libinstaller.so.5 ${LOCALBASE}/lib/libinstaller.so
46         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/commands.h ${LOCALBASE}/include/installer/
47         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/confed.h ${LOCALBASE}/include/installer/
48         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/diskutil.h ${LOCALBASE}/include/installer/
49         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/functions.h ${LOCALBASE}/include/installer/
50         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/package.h ${LOCALBASE}/include/installer/
51         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/uiutil.h ${LOCALBASE}/include/installer/
52
53 OSTYPE!=sysctl -n kern.ostype
54
55 .if ${OSTYPE} == "FreeBSD"
56 .include <bsd.port.mk>
57 .endif
58
59 .if ${OSTYPE} == "DragonFly"
60 .include <bsd.dfport.mk>
61 .endif
62