Merge from vendor branch BZIP:
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-dfui / Makefile
1 # New ports collection makefile for:    lua50-dfui
2 # Date created:                         21 Feb 2005
3 # Whom:                                 Chris Pressey
4
5 PORTNAME=       lua50-dfui
6 PORTVERSION=    0.1
7 INTERNAL=       YES
8 CATEGORIES=     devel
9 DISTNAME=       luadfui-${PORTVERSION}
10 WRKSRC=         work/dfui
11
12 LIB_DEPENDS=    lua50.5:${PORTSDIR}/lang/lua50 \
13                 aura.3:${PORTSDIR}/devel/libaura \
14                 dfui.4:${PORTSDIR}/sysutils/libdfui
15
16 BUILD_DEPENDS=  ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
17 RUN_DEPENDS=    ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51 \
18                 ${LOCALBASE}/lib/lua/5.0/lposix.so:${PORTSDIR}/devel/lua50-posix
19
20 MAINTAINER=     cpressey@catseye.mine.nu
21 COMMENT=        DFUI binding for Lua 5.0.x
22
23 PLIST_FILES=    lib/lua/5.0/ldfui.so \
24                 share/lua/5.0/dfui.lua
25
26 do-fetch:
27         @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then                \
28                 ${ECHO_MSG};                                                    \
29                 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!";   \
30                 ${ECHO_MSG};                                                    \
31                 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved";   \
32                 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the";       \
33                 ${ECHO_MSG} "BSD Installer CVS repository.  Please see the shell scripts in the";       \
34                 ${ECHO_MSG} "scripts/build directory of the repository for more information on how";    \
35                 ${ECHO_MSG} "to create these distfiles.";                       \
36                 false;                                                          \
37         fi
38
39 do-install:
40         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/ldfui.so ${LOCALBASE}/lib/lua/5.0/
41         ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/dfui.lua ${LOCALBASE}/share/lua/5.0/
42
43 OSTYPE!=sysctl -n kern.ostype
44
45 .if ${OSTYPE} == "FreeBSD"
46 .include <bsd.port.mk>
47 .endif
48
49 .if ${OSTYPE} == "DragonFly"
50 .include <bsd.dfport.mk>
51 .endif